About SNAP operating speed

Hi, everybody.I want to ask a simple question for every expert but the question is difficult for me.
Why the snap64. exe still go on even I have closed the software?The circumstance is the physical memory can up to 90% and above. I don’t know the reason.
To accelerate the computer operating speed , I have to stop the snap64. exe manually.

I don’t see this when I run SNAP. What operations did you do when SNAP was running? If you just start SNAP, wait for it to fulling start and then shut it down maybe wait a couple of minutes and then is it still running in the task manager? Or is it after starting some processing and then shutting down?
What version are you using and what OS?

Thanks for your reply.:grin:
The version is SNAP 5.0 and Window 7 OS.I encounter the second circumstance you said.However,I just try again if I just start software and do nothing then I close SNAP, SNAP64. exe also will not exit automatically after 5 minutes.The physical memory is less than 50% because the SNAP64 just occupy smaller space than after some processing .
So my problem is why the SNAP64. exe can not exit automatically when I have close it.I have to stop snap64. exe manually every time.That’s terrible.
Thanks a lot.:grin::grin::grinning:

Maybe the log file in C:\Users\lveci\AppData\Roaming\SNAP\var\log will have some clues.
It should have at the end

INFO [org.esa.snap.rcp.SnapApp]: Request to stop SNAP Desktop
INFO [org.esa.snap.rcp.SnapApp]: Stopping SNAP Desktop

Thanks for your reply.
I have found there is no the two lines in the log file you mentioned.so I tried to add these lines at the end.
However, SNAP64. exe still can not exit automatically after I closed software.I don’t know why.

Thanks for your patience.:smiley:

Adding the lines to this file, does not change anything. The file contains only informative output of SNAP.
Can you attach the file here so we can have a look. Maybe we see some issue.

Great,Thanks you.
I have attached the message.log.

messages.log (78.4 KB)

The only unusual I see is:
Terrain-Correction$15B384149D4 error: no valid output was produced. Please verify the DEM
@lveci Does it tell you something?

@Falcon-Baikal I see that you haven’t updated SNAP. Several modules can be updated. I think this will not solve the issue, but you never know…

I don’t think the line you noticed is related to the SNAP64. exe , DEM was output when I put several S1 images to Terrain Correction.
Update will be tried later. Thanks for your reply.Thanks.:smile::smile:

The terrain correction message occurs when nothing was produced as output by the operator. This could be caused by the DEM where there may not be any valid data within the scene (for example in ocean or at the poles) or possibly the input data was all no data value.

Yeah,you are right.The images I used cover Canadian island.Although I know that,I still thanks for your reply.Thank you very much.
If I can’t solve the above problem,I will repost here.Thanks.

I’ve occasionally had this issue running SNAP on my MacBook Pro. It’s happened with different versions of SNAP and on different OSX versions. I never looked at the logs because I just killed the process directly and that was it. If it happens again, I’ll be sure to record the log info.

One option to try is to add


To the snap.properties file in <snap_install_dir>/etc.
Then more output should be shown in the log files and this might give some hint for the cause.