Access".snap" using Linux

Hi everyone,

I want to use Linux to derive DEM from S1, and I am using an external DEM for the whole process. I added the external DEM to the right directory: zipped the DEM,and added to .snap–> auxdata–> dem.
As far as I understood, “.file” is a hidden file in the Linux environment, and that is why I can’t navigate to it to add my external DEM to the Process of DEM generation under Linux environment.
Is there a way to make Snap toolbox “sees” the .snap?
I am using “Mobaxterm” to connect to the Linux server.
I will greatly appreciate your suggestions.

I also tried “Is -a” command to unhide the “.snap”, it didn’t work for me!

It is hard to determine why you are having a problem from the information you provided, but such problems are generally due to misunderstanding how linux manages files and directories. You may have permission problems or you may be looking in the wrong place. Your best bet is to look at a good linux reference to solidify your understanding and clear up misconceptions.

You are right that “dot files” are “hidden” (meaning that that won’t appear in an “ls” listing unless the “-a” option is provided). You can, however, see the contents of
the “~/.snap” directory with “ls .snap” in a terminal. You may be expecting “ls -a” to toggle the hidden property, which is a common misunderstanding for people comming from a Windows background. If you are using a GUI file browser there should be an option you can set to make “hidden” files and directories visible in the GUI, but that won’t change what you see in the terminal.

When teaching practical sessions for workshops on ocean remote sensing students found it very helpful to spend an afternoon just focusing on some basic linux command-line concepts – navigating directories, managing files and file permissions, editing text files, etc. There are a number of good online resources, many available in multiple languages. Have a look at Linux Command. If you are using Debian or a derivative such as Ubuntu, you can install a Debian Reference Manual as a distro package.

1 Like

Hi, thanks a lot for your reply. You are right by saying I am new in Linux environment, and I am familazing myself with it.

With a help of my colleague we found a work-around for this problem.
We created a link it to the .snap, and then I was able to access " .snap" from SNAP software.
It seems the problem solved.
Thanks again for your time,
Best regards