After tiling views - one is lost


#1

Hi all.
I had problems with multiple views.
In particular, when i want visualize n views (for example 4 RGB views) using “tile vertically” and “tile evenly”, Snap shows only n-1 views and hides one view.
Is this just my problem?
Thanks!


Issues/Observations/Comments of SNAP 6.0 Beta
#2

@annamaria: Just to go sure: are all of them projected and of the same pixel size? Is it always the same product which is hidden or is it a rather systematic issue?


#3

I have noticed that there’s something odd with Tile Evenly etc. already several SNAP versions ago. It looks like sometimes the workspace is split into two (this is evident by looking at the controls), which then generates weird behaviors.

An exact series of step needed to recreate the bug would be a good start…


#4

Are the views all from the same product or from different products?
Can you tell the name of the products and how you create the RGB views?
I just tried it and it worked well. So, there must be something specific.


#5

If I remember correctly 5 linked views caused trouble with Tile Evenly, not sure if one of the needs to be a RGB or not.


#6

Dear @marpet,dear @mengdahl, the problem is systematic.
It happens (with my workstations) both with S1 and S2 images.
For example you can use S2A_MSIL1C_20171027T103131_N0206_R108_T32TLR_20171027T141000.
In this case, if I create three RGB views and after I use tile evenly, Snap shows only two views and it hides the other one.
Thank you all, very much.


#7

For a better overview, I’ve extracted this discussion from the other thread.
I’ve tried to reproduce it but till now I haven’t seen that one view is hidden.
However, I have added your report to our issue tracker and we will further have an eye on it.

Maybe the view gets back when you try from the menu: Window / Reset Windows
Don’t be scared if SNAP application disappears completely. It will come back after a few seconds. Hopefully. :wink: