Back-Geocoding after TOPSAR-Deburst gives blank slave

Hi everybody.
I want to find the coherence in a wide area, and that’s why I want to subset to Sentinel-2 tiles each SLC file (after splitting to the IW2, VV, Bursts 1-9, and applying Orbit File) and after that to do back-geocoding and several steps after that.
Since one of those steps is TOPSAR-Deburst, and it seems that it can’t run after subsetting, I want to do it before the subsetting - but that causes the following weird problem: when I do the Debursting before the backgeocoding, I get a blank slave image (note that everything works fine when backgeocoding without the deburst).
I’m working with updated snap 9.0, on a strong Azure VM with a lot of memory. I tried to uncheck the ‘maskOutAreaWithoutElevation’ flag and run it with every option for ‘demName’ that is running. Also, I tried on another file, both from GPT and SNAP GUI.

Please help me :pray:

Did you ever manage to solve this probem? I have the same issue for current Sentinel-1A data