Beta OTB Adapters available

A Beta version of Orfeo Toolbox SNAP Adapters is available for tests. These adapters allow to launch from SNAP some of the main OTB tools (4 Segmentation tools, 3 Pan-Sharpening tools, SFS Texture Extraction and Multivariate Alteration Detector)

To install them is first required to set-up a new update center. From SNAP, go to tools/plugins then click on the Settings tab and press the “Add” Button to add a new update center. Put the name of your choice and in the URL field. The OTB Adapter will appear in “Available plugins”. Select the module and press the “Install” button to install them.


  • OTB Tool needs to be installed separately from the adapters. For more information you can read the dedicated SNAP Help page under “Sentinel Toolbox Application/Optical/Orfero Toolbox”.
  • Once the adapters are integrated in SNAP/Sentinel-2 Toolbox the specific update centre will be suppressed.

We hope to get many feedbacks to improve these adapters.


great news, I love the idea to use OTB tools in SNAP. I’ll have a look at it, thank you!

unfortunately, I don’t get any outputs. When I execute the segmentation for example, the tool starts runnung and nothing happens.
I have set an output directory and checked it but creates no data.

Any ideas why this happens?

Thanks for your feedback.

Segmentation create shp files that are not opened directly by SNAP. The shp file is created by default in /tmp (C:\tmp or D:\tmp under windows). You can change that by changing the “Output vector file”, but the file should be a “.shp”.

Once the file is created, after opening an image from the SNAP Layer Manager you can add the layer as an ESRI shapefile.

1 Like

thank you for your suggestion, Nicolas.
I have set an output folder (C:\Temp) but it’s empty. I also think that the segmentation could not be performed within 2 seconds.

Indeed 2 seconds is too short…

Error reporting was greatly improved in SNAP with resolution of SNAP-448 but these changes are not published yet. For the moment you can look at the logs in the following file from your home directory: AppData\Roaming\SNAP\var\log\messages.log. Could you send us this file? What product do you use as input?

1 Like

I used a small subset of RapidEye data for testing purposes.

This is the logfile:
messages.log (51.5 KB)

Thanks for the logs. OTB tools are working with image file as input and here the file “clip.dim” sent to OTB is not an image. Could you try directly with a tif file in the RapidEye product?

Two issues were created for this: SIITBX-218 and SIITBX-219

1 Like

thank you Nicolas for the reply. I tried it with a tif file instead but experience the same behaviour.

messages.log (53.5 KB)

However, when I run the OTB secmentation from QGIS I get a result at least.

I had a try with a 681KB tif file coming from a RapidEye product, launching segmentation-cc with your parameters. It took 4 second, segmentation-cc.shp file was created in D:\Tmp, I could add this shp as a layer of the tif image and result looked ok.

If no file is created on your side we have to look for the differences between our configurations. Did you update to the latest version of SNAP? How did you install OTB? What OS are you using? Thanks in advance.

Thank you for testing.

  • I had a 1.399 KB tif from RapidEye
  • latest Version of SNAP is installed (3.0.4)
  • I downliaded the official zip-file binaries for Windows 10 64 bit and set this folder within the plugin preferences as OTB_BIN

I just wanted to tell that I tested it on another computer and it works. I can’t tell the difference at the moment and the results are not as expected but that mainly depends on the input data and the parameters.

So thank you for implementing! I’ll give you news in here when I received good results.
Does anyone have experience with sementation of SAR images?

Thanks for you message. We didn’t find where the problem could come from neither, there were not information on the log and the exact same command line was working here.

Thanks for telling if you see any problem or get results.

could there be a compatibility issue?

could you guys please have a look at this topic?
I often use OTB tools in QGIS and they perfectly work but It seems that we are missing something when applying the OTB modules in SNAP.

I have allready installed the OTB adapter but it dosent work yet.
please help me

please follow the instructions by obarrilero given here: Error with OTB segmentation-meanshift