Blank Slave after S-1 TOPS Coregistration


after performing the S-1 TOPS Coregistration with the following S-1 IW SLC´s I receive a blank Slave as output.

S1A_IW_SLC__1SSH_20150919T154517_20150919T154544_007786_00AD50_6092 (Master)
S1A_IW_SLC__1SSH_20151001T154517_20151001T154545_007961_00B20D_1BA0 (Slave)

SNAP 2.0 Beta 08, Operating System Win 7 64bit, 6GB RAM.

I am basically trying to follow the TOPS Interferometry Tutorial (Issue May 2014). Restituted orbits were applied. Area of interest is Tunabreen Glacier (78.4968, 17.4321) on Svalbard, therefore the ASTER GDEM is used for Geo-Backcoding.

The resulting master layers appear to be OK, but the slave is blank / empty and doesn´t contain any information (Min/Max = 0).

No other preprocessing was performed.

This also happens if I change the above mentioned master to slave and use the following S1A IW SLC as master:

Any help is highly appreciated!

With best regards,


Note that the ASTER DEM is not automatically downloaded like the SRTM is. This is due to the restrictive distribution license of the ASTER DEM. You need to download the tiles yourself and place them in the .snap/auxdata/DEMs/ASTER folder.

In my experience the GETASSE30 DEM is good enough for co-registration in arctic regions - that one is available seamlessly so you do not need to download ASTER tiles by hand.

Thank you for your answers.

I was able to solve the issue in the last days by using the ACE-DEM. As for as I understand by now the ASTER GDEM should not be used snow covered surfaces anyway.

Regarding the download of the ASTER GDEM I suggest to implement message / notification to make it foolproof.

be careful the ACE dem does have artifacts is some places but then again
so does ASTER

Hi @ Lveci about the issue black slave after S-1 TOPS Coregistration, I have been facing with that problem too, I using 1 master 4slave images (image attached ), you mentioned download SRTM how I download that file
and second I’m learning using PSI, in snap processing how many slaves and masters image we should use ??
Thank you so much for your time

If you are using SRTM 3 sec make sure you have the latest updates 6.0.5

Hi Lveci, yes I will try it again thank you for your helping !!

Hi Luis, thank you for your help before, After I fixing the problem then I try Stamp export the result from snap processing, then It turned out the error again (image attached) first the error is exist band then I delete all the band then I add elevation band but the result is another error, do you know how can I fix this error thank so much again for your help
Tran Rick,


I receive a blank slave after S-1 TOPS Back Geocoding. I use a S-1 IW SLC data with 32bit floating DEMNAS external DEM (Indonesian DEM) from DEMNAS has a resolution of 8 m and WGS 1984 (EPSG: 4326) projection.

I have tried to resampled it to 10 m resolution. I also subset the image so the DEM could cover it. I tried the step with SRTM3sec autodownload DEM in SNAP and it works, but I still have to use this DEM for my thesis purpose.

I would like to know if there is any requirement for external DEM to be used in SNAP software. Thanks.


1 Like

hi there for me I have blank problem after backgeocoding then I change (Parameter in S-1 backgeocoding "SRTM 3sec (Auto Download to SRTM 1sec HGT(Auto…) then I can overcome the problem!!

Hello, I am having trouble with S1-TOPS-coregistration with ESD. After the coregistration, the master intensity band shows up, but the slave intensity band does not. This is after updating and restarting the application.