Bug in Graph Builder in connection with RD Terrain Correction?

Dear all,

I just noticed that the Range Doppler Terrain Correction produces different results when used within the Graph Builder.

To be more specific: When doing RD Terrain Correction, you have the possibility to uncheck the option “mask out areas with zero elevation”, which will not mask out marine areas. If I create a processing chain in the Graph Builder where RD Terrain Correction will be the last step and I do uncheck the option “mask out areas with zero elevation” and run the whole chain, SNAP will mask out marine areas anyway. This is quite annoying as I’m interessted in costal areas including both land and marine areas.

Did anyone else see this strange behavior before? What can I do, if I want to apply my processing to a larger number of scenes, if SNAP keeps masking out marine areas when executing graphs?

Thanks a lot…

Can you share your processing graph? We just want to make sure it is Terrain Correction that masks out the marine area.