C2RCC MSI Processor problem [SOLVED]


I have installed C2RCC following the steps in bcdev/s3tbx-c2rcc - Libraries.io (including the instalation of SNAP 4). I installed C2RCC as SNAP plugin. When I try to use the C2RCC MSI Processor over Sentinel-2 MSI products I get the following error:

Any help would be appreciated!!!

Best regards,


Dear Javier,
since SNAP 4 the view angle bands are named and treated differently which causes the c2rcc code not to work anymore. We’ll see to fix this soon.
As a quick solution, the code will work with SNAP 3.

Dear Tonio,

I had to upgrade to SNAP 4 since there was 8 dependencies of libraries with version 4.

Is there any way to solve these dependencies without installing SNAP 4?

Thank you very much!


No, as the dependency problem only occurs because of SNAP 3. You should be able to solve this by changing the snap.version from 4.0.0 to 3.0.0 in the pom.xml located in the root project directory. This should allow you to still use SNAP 3.

1 Like

Thank you very much!!! Much better solution than mine. I checked out the version 0.11 in order to be able to use SNAP 3.0…

Best regards!


Hi Javier,

I also want to point out that the C2RCC processor is not yet intended for productive use. We haven’t made it publicly available because the results are not fully verified and validated, although the first results look promising. That’s why it still has a 0.x version number. So please use the results with care and don’t use it for publications or productive data processing.


Dear Marco,

thank you very much for your advice. You are doing a great job. We will use C2RCC with care!!!


Dear Tonio,

I’m having exactly the same issue. I had SNAP 3.0, the C2RCC processor could not be installed because of the dependencies, I installed SNAP4.0 and now I get the same error on ‘view_zenith’ as Javier. However, I cannot find this pom.xml file. Could you help me?

Thanks in advance!

Which version are you using?
With version 0.12 it should work.

Just send it to you.

Hi Marco,

Yes, with version 0.12 it works!

Thanks a lot!


Hi Marco,
and all others reading here,

C2Rcc v0.12 in SNAP4 did not work for me
(Error like Javier ‘view zenith’)
but C2Rcc v.014 works!
Thank you, Marco!