Can not open sen3 xml file

I am running SNAP 4.0.2 on Windows 7 64 bit.
I tried File > Import > Optical sensors > Sentinel-3 > Sentinel-3
I have some small ROI subsets of L2 OLCI data and I chose the xml file. This generated an error “No appropriate product reader found.” The filename I selected is “xfdumanifest.xml” and the dataset is “S3A_OL_WFR____20160823T234213_20160823T234218_20160825T053514_0179_008_030_3240_MAR_O_NR_001_ROI_GEO_LUCI_AER.SEN3”
I can read the individual netCDF files by importing generic netCDF.
My message log file ismessages.log (73.5 KB)
attached - I see some warnings about modules not unpacked but don’t know if this is relevant.

This is now resolved - when I downloaded the data again it worked. I think the root directory name was incorrect.
I can’t see how to remove the post.

It seems that the filename does not follow the naming convention.
Actually it should start with “S3A_OL_2_WFR___2016…”
I think this is the reason why it is not detected as a proper OLCI product.
From where have you got this product?

Thanks, I discovered that the file was named incorrectly too – I had changed the name of the top directory.
I am doing work with Thomas Schroeder in the s3vt and got the data that way.
It is working now.

Say kind regards to Thomas.