Cannot download previous versions of Snap

*This question may seem stupid but please bear with me, I am only a Geography undergraduate student *


I am trying to obtain some land subsidence data as part of my third year undergraduate dissertation. I’ve never used Snap or stamps before, so I’ve been following the instructions I found on youtube - RUS webinar: SNAP2StaMPS – Data preparation for StaMPS PSI processing with SNAP - HAZA09 - YouTube

After jumping thorough many hoops, I’ve finally gotten to the last stage of the first part of this exercise where I perform the stamps export. However, it seems as though the processing is ‘stuck’ (i.e. no progress, and no error message - Nothing happens).

Browsing this forum, I tried all the possible solutions to ameliorate this issue, but to no avail. After finally exhausting all my options, I’ve decided to try performing this final step using Snap 7.0. My line of reasoning follows the fact that in the video tutorial, they specified that we should use an older version of python (2.7.12) for the processing to work, despite there being a newer version out (something to do with compatibility). The video tutorial used Snap 7.0 and the stamps export process was seamless.

For the same reason that they used a previous version of python, I want to use the previous version of Snap. Now, here comes the question - why is it that I cannot download the previous versions of snap? I’ve found the page where I SHOULD be able to, but upon clicking the link, nothing happens. I’ve tried this on 2 different computers and the result was the same. Have they removed the download for Snap 7.0?

Any and all help will be appreciated. I’ve been stuck on this step for almost 2 weeks now :cry:.

Any reasonw hy you made a new topic?
We discussed this already here: Problem in the last part of snap to stamps - #81 by Tristopher1

This is the third time that this is being reported in very short time by different users. I wonder if all these cases belong to the same course and why your lecturer/supervisor did not make sure in advance that the suggested tutorial is working correctly…
With a recent update of SNAP the StaMPS export has issues when trying to download a DEM.

In the previous topics, we discussed a possible fix for Snap 8.0 (which has not been resolved).

In this situation, I’m asking how I can get a previous version where there may not be compatibility issues. I’m not even sure if it is compatibility issues that is causing these problems but if the recent update of Snap has issues with the stamps export, I thought I might as well give it a try using Snap 7 as that’s what they used in the tutorial.

I assure you that this has nothing to do with my supervisors. I looked online to see if I can get some land subsidence data and this seems to be the most appropriate method. I’m simply trying to teach myself something not covered in my course to ensure that my analysis on local sea level rise is as accurate as can be, which also explains my tenacity in trying to resolve this issue.

Maybe the reason why there are many reports is because other people are trying to perform the same analysis and find that the software has been failing them.

If it’s only about downloading previous versions: I just checked and I can download the 7.0 installers for Windows 64-Bit, Mac OS X and Unix 64-bit. The Windows 32-Bit installer is not available but I guess it is not required in your case, right?

Have you used this page? Previous Versions – STEP

The thing is - StaMPS does not officially belong to SNAP. The SNAP developers do their best to make transitions between different software packages as easy as possible. But ESA can’t guaranty that all these work continuously.

Yes, I’ve been using that page to try and download the previous version but when I click the 64-bit windows downloader, nothing happens.

I’ve also tried downloading it on another computer, but I get nothing.

Then it is a browser issue. Just downloaded all of them.
Please try this direct link: SNAP 7.0 (Windows 64 bit) (right-click > save target as…)

Also another note: The previous versions are provided by ESA to support operational workflows which might be dependent of a certain version or functionality, but they can contain bugs in other parts of and no official support can be provided.

@ABraun the download worked, and I tried running the stamps export. Unfortunately, it did not work. Hopefully an update comes out soon where everything will be resolved.

Thank you very much for your time and patience.

To me, that is no surprise, because SNAP 7.0 looks for the old SRTM which is no longer there. You can try to manually replace the SRTM location as suggested in the FAQs. A process related to digital elevation models is taking forever to finish

Yes, I’ve tried changing download address in the but that does not have any effect.

I don’t really know how to do select the SRTM 1Sec (AutoDownload) instead through the terminal, although I have a hunch that its not applicable for my situation.

@ABraun, sorry for bothering you again.

I just wanted to know if, possibly, the stamps export tool will be fixed in the next 2 months. I’m asking this because I am to present my current findings on my project and I’m wondering if I should talk about the possibility of incorporating the rate of land subsidence (obtained by following the snap-stamps workflow) in my project.

I would like to avoid making potential ’ false promises’ in the event that it is not resolved by then and I feel like you may have an answer to this.

Thanks in advance.

What is the issue with stamps-export with fully updated 8.x?

Hello @mengdahl.

Bascially, I’ve been trying to use the stamps-export through the windows terminal (following instructions from the RUS Copernicus training program HAZA09).

When I tried to run the code, it seems to get ‘stuck’ at a certain point. No matter how long I wait, nothing happens, as seen on the attached image:

I’ve tried this on both SNAP 7 and the updated version of 8.

I spot both a backslash and a frontslash in the same path/command.

I think that was done automatically. How would I go about fixing this? I did not write the code.

I took at look at the file and there are two lines that might attribute to this:


should I change the 'forward slash ’ to a ‘backslash’ ?

Check for Unicode lookalike quote characters contributed by some overly helpful editor.

When entering backslash in a string you often need to use a double backslash:


I’ve changed it to what you suggested. However, the result has not changed - it’s been stuck like this for almost half and hour.