Cannot open Landsat data


#1

I tried opening the LE07_L1TP_197024_20090920_20161217_01_T1_MTL.txt in SNAP.
But it doesnot open.


#2

please provide more information.

Where did you download the data?
How did you import it?
Which error message pops up?


#3

I downloaded it from the USGS
I tried importing the MTL.txt file
The error message is below:


#4

Did you open the MTL file by the import function?
I just tested it and had no problems with the data.


#5

Yes. I did try opening it with the import function.


#6

This is what you need to select

Then chose the MTL file

Do you use the latest version of SNAP?


#7

Yes. I did the same.
i have the latest version of SNAP


#8

was the data fully downloaded? My folder has 861 MB (extracted size)


#9

Yes. It was fully downloaded. Still not working.
I will download it again and give one more try.


#10

I just tested, it should also work by simply using the “open product” button


#11

Okay. i will download it again and give it a try.


#12

The problem got solved. There was a problem with the data.
Thank you so much for your help.