Cannot Open S1 GRD zip in esa_snappy?

So I have installed the SNAP 10 to linux using the .sh file.
I have also configured my python path for using esa_snappy.
But whenever I try to read grdh zip file I keep getting the following error.

I have also tried removing the .snap/auxdata/gdal folder.
And have already installed SNAP 10 again bit nothing helped.
Also, same goes for gpt xml files.
In gpt i’m able to read .dim files but not .zip or .safe.

Can you help what am I missing here?
Is is something to do woth Gdal Installation as I have note downloaded gdal separately as I know SNAP comes with its own internal GDAL.

Im pusing python 3.10.13

>>> from esa_snappy import ProductIO

Error while parsing JAI registry file "file:/home/ec2-user/esa-snap/snap/modules/ext/org.esa.snap.snap-core/org-geotools/gt-coverage.jar!/META-INF/registryFile.jai" :
Error in registry file at line number #31
A descriptor is already registered against the name "org.geotools.ColorReduction" under registry mode "rendered"
Error in registry file at line number #32
A descriptor is already registered against the name "org.geotools.ColorInversion" under registry mode "rendered"
Error while parsing JAI registry file "file:/home/ec2-user/esa-snap/snap/modules/ext/org.esa.snap.snap-core/org-jaitools/jt-zonalstats.jar!/META-INF/registryFile.jai" :
Error in registry file at line number #4
A descriptor is already registered against the name "ZonalStats" under registry mode "rendered"
WARNING: org.esa.snap.core.util.ServiceLoader: org.esa.snap.core.gpf.OperatorSpi: Provider eu.esa.opt.meris.sdr.aerosol.AerosolMergerOp$Spi not found
WARNING: org.esa.snap.core.util.ServiceLoader: org.esa.snap.core.gpf.OperatorSpi: Provider eu.esa.opt.meris.sdr.aerosol.ModisAerosolOp$Spi not found
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.esa.snap.runtime.Engine (file:/home/ec2-user/esa-snap/opttbx/modules/ext/eu.esa.opt.opttbx-c2rcc/org-esa-snap/snap-runtime.jar) to method java.lang.ClassLoader.initializePath(java.lang.String)
WARNING: Please consider reporting this to the maintainers of org.esa.snap.runtime.Engine
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
SLF4J: No SLF4J providers were found.
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See for further details.
SLF4J: Class path contains SLF4J bindings targeting slf4j-api versions 1.7.x or earlier.
SLF4J: Ignoring binding found at [jar:file:/home/ec2-user/esa-snap/snap/modules/org.esa.snap.snap-netcdf/org-slf4j/slf4j-simple.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Ignoring binding found at [jar:file:/home/ec2-user/esa-snap/snap/modules/ext/org.esa.snap.snap-netcdf/org-slf4j/slf4j-simple.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See for an explanation.
INFO: org.esa.snap.core.gpf.operators.tooladapter.ToolAdapterIO: Initializing external tool adapters
INFO: org.esa.snap.core.util.EngineVersionCheckActivator: Please check regularly for new updates for the best SNAP experience.

>>> s1 = ProductIO.readProduct("/home/ec2-user/rishabh/")

SEVERE: org.esa.snap.dataio.gdal.GDALLoader: Failed to initialize GDAL native drivers. GDAL readers and writers were
Native library load failed.
java.lang.UnsatisfiedLinkError: /home/ec2-user/.snap/auxdata/gdal/gdal-3-7-2/lib/jni/ /lib64/ version `GLIBC_2.27' not found (required by /home/ec2-user/.snap/auxdata/gdal/gdal-3-7-2/lib/jni/../
SEVERE: eu.esa.sar.iogdal.sentinel1.Sentinel1ProductReader
'int org.gdal.gdalconst.gdalconstJNI.GDT_Unknown_get()'
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
RuntimeError: eu.esa.sar.iogdal.sentinel1.Sentinel1ProductReader
'int org.gdal.gdalconst.gdalconstJNI.GDT_Unknown_get()'```

Hi Rishabh,
Can you please let me know how you configured esa_snappy for SNAP 10? I have tried every possible way, but still cant configure it.

while you are installing it will ask for python executable path which you need to give. Which will create snap-python folder inside .snap folder.
Then you can copy esa-snappy folder which is inside .snap/snap-python and move it to site packages folder of the respective python exceutable which you shared.

Alternatively there is a snappy-conf in the folder esa-snap/bin , which can do this for you.
refere this for more troubleshooting =>

This is an OS issue where GLIBC version was 2.26. I was using Amazon linux 2 image for my ec2 server. Could not update it so I have shifted to Amazon linux 2023 image where the GLIBC version is upgraded.

Hi Rishabh,I am using Windows operating system, how can I solve this problem on Windows operating system?

What is the exact error you getting? is it an issue with GLIBC files missing or version mismatch?

I’m having exactly the same problem as you mentioned above.I’m using SNAP10.0.0 and the Python version is 3.6 and 3.9 have been tried. But there are also errors.

If you can share the whole error message i can help. I don’t see anything mentioned about GLIBC in the error message?

Hi Rishab,

I am facing quite similar problem. Zip file not reading, yet the *dim test file does,

PS: I’m using Windows10 OS - python 3.8 - SNAP 10+

Rendered errors are in the following shot. Any hint ? Best