Can't export product as PCIDSK file (under gdal) in SNAP v6.0

Hi all,

I’m super new to SNAP (just started using it today). I’d like to use SNAP to clean up some Sentinel 1 GRDH images for further processing using PCI Geomatica (mainly creating DEMs from stereo-images).

The only file format that Geomatica seems to like is either the original file included in the S-1 download or a PCIDSK (.pix) file. After some trial and error exporting in SNAP, I see that you should be able to export as GDAL, with one of the file extension options being PCIDSK. However, when I try to export as .pix, I get an exception as follows:

java.lang.UnsatisfiedLinkError: org.gdal.gdal.gdalJNI.GetDataTypeName(I)Ljava/lang/String;
at org.gdal.gdal.gdalJNI.GetDataTypeName(Native Method)
at org.gdal.gdal.gdal.GetDataTypeName(
at org.esa.s2tbx.gdal.WriterPlugInExportProductAction.exportProduct(
at org.esa.s2tbx.gdal.WriterPlugInExportProductAction.actionPerformed(
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.AbstractButton.doClick(Unknown Source)
at com.jidesoft.plaf.vsnet.VsnetMenuItemUI.doClick(
at com.jidesoft.plaf.vsnet.VsnetMenuItemUI$MouseInputHandler.mouseReleased(
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$500(Unknown Source)
at java.awt.EventQueue$ Source)
at java.awt.EventQueue$ Source)
at Method)
at$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
at$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue$ Source)
at java.awt.EventQueue$ Source)
at Method)
at$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
[catch] at org.netbeans.core.TimableEventQueue.dispatchEvent(
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at Source)

I thought perhaps I don’t have the correct gdal package installed, but I checked and have gdal v2.1.3 installed under the snap auxdata folder.

Any ideas as to how to correct this exception? Or how to update files with corrections made in SNAP (namely Apply Orbit File and Mulitlooking)?


I can save a simple mapped image to PCI Geomatica .pcx format on a Windows 7 64-bit system. I have 64-bit SNAP6 and GDAL is .snap/auxdata/gdal-2.1.3-win64.

java.lang.UnsatisfiedLinkError: org.gdal.gdal.gdalJNI.GetDataTypeName(I)Ljava/lang/String; could mean
a 64-bit verus 32-bit problem or (since this is Windows) that some other version of the library in question was prevously loaded by another program. Do you have the problem if you reboot and run SNAP immediately afterwards?

Hmm, I’ve tried rebooting and running SNAP immediately after, with the same error result.

I’ve just checked my installations, and I also have 64-bit SNAP and GDAL is .snap/auxdata/gdal-2.1.3-win64.

Any other ideas?

The next step is to try using SNAP’s version of gdal in a CMD window. Do this in two steps:

  1. add the directory with the GDAL programs to the PATH:

     > PATH=%USERPROFILE%\.snap\auxdata\gdal\gdal-2.1.3-win64\bin\gdal\apps;%PATH%

Try running gdalinfo:

    > where gdalinfo
    [... other gdalinfo versions]
    > gdalinfo

This should give an error: “The program can’t start because gdal201.dll is missing from your computer. Try reinstalling the program to fix the problem.” If some other program has installed the gdal201.dll library,
you should get a different result.

Next, add the library directory to the PATH:

    > PATH=%USERPROFILE%\.snap\auxdata\gdal\gdal-2.1.3-win64\bin;%PATH%
    > where gdalinfo
    > gdalinfo
    Usage: gdalinfo [--help-general] [-json] [-mm] [-stats] [-hist] [-nogcp] [-nomd]

                                    [-norat] [-noct] [-nofl] [-checksum] [-proj4]
                                    [-listmdd] [-mdd domain|`all`]*
                                    [-sd subdataset] [-oo NAME=VALUE]* datasetname
    FAILURE: No datasource specified.