Can't open link SNAP 2.0 beta testing registration

Hi, I received the registration email for downloading the beta release for sentinel 2 toolbox but it doesn’t work.
Someone can help me.Thanks in advance.


Probably it is because you are using Internet Explorer or Edge from
Either you can use a different browser (e.g. Firefox or Chrome) or you
copy the link to the clipboard, paste it into the address bar and remove
the login data at the beginning.
Hit Enter and provide the login data when you are prompted.


Thank you, it works on a different browser.


I am interested in the SNAP for Unix , but it doesnt seem to work correctly. I’ve tried to installed it on Ubuntu from the terminal with the following commands (which worked with previous versions):

sudo chmod +x
sudo ./

and I get this error:
“gzip: sfx_arcive.tar.gz: not in gzip format. I am sorry, but the installer file seems to be corrupted. If you downloaded that file please try it again. If you transfer that file with ftp please make sure that you are using binary mode.”

Anyone knows how to fix this?
thanks a lot in advance!

Hi Simone,

I had the same problem when I downloaded the script through my browser (Chrome).
Solved it by downloading in a shell using wget:


Then installing works like you suggest.

Hope it helps.

1 Like

Thanks very much Jelte, that works!!
cheers, Simone