Can't open Tiff/GeoTiff in SNAP

Hi everybody,
I tried to open surface reflectance Landsat bands in tiff format in SNAP and I get this error:
GeoTiff image reader not found.

I tried with S1TBX and NEST and I get this message:
An exception occured:
Message: GeoTiff image reader not found

Any idea how I can solve this?


Actually the GeoTiff reader is one of the core components and it should be there.
Which version of S1TBX have you used? Still a 1.x version?
If so, please try the current beta version.
Where have you downloaded the Landsat data? Was it USGS, DLR, Amazon?
Normally it should be possible to simply select the ****_MTL.txt file and open this in SNAP. Then all Landsat bands are opened in one product and you don’t have to deal with the single band files.

1 Like

I’m using the last version of SNAP.
The landsat images are from usgs, atmospheric corrected. They come in tif
files without the mlt.txt
I also tried with other tif file but it gives the same error and I can’t
understand why. I tried in two different machines, one with win 7 the other
with win server 2012

So you are not using Landsat 8? At least I don’t know of atmospheric corrected Landsat 8 data?
For Landsat 8 there should be an MTL file according to the documentation provided by USGS.
Probably it would be good if you provide such a tif file or tell me where and how I can get such a file

Yes I’m using L8 downloaded from
Anyway the same problem happen with other tif too.
The problem seems to be with geotiff reader but I don’t know how to fix that.
Thanks a lot for your support!


My mistake…what I was trying to open were tif files produced with ENVI. The tif downloaded from USGS work fine.
Sorry for that!

Nevertheless, some tif created with GDAL are also not working giving this error:

OK, No problem.

Regarding the ClassCastException. Can you provide the messages.log file where the exception text is written to.
You will find it in your user home directory.
On Windows: %USER_HOME%\AppData\Roaming\SNAP\var\log\messsages.log
On Unix: %USER_HOME%.snap\system\var\log\messsages.log
Probably this will help to find the reason for the exception.

Here it is:

The error occurs in one of the libraries we use.
I haven’t experienced such an error before. Can you provide an example file?

P.S. Did you know that you can directly attach a file to the post?
It’s the icon in the menu above.