Can't read S2 commissioning sample data

Hi there,

I’ve tried to open the S2 sample file recently made available for download (S2A_OPER_MTD_SAFL1C_PDMC_20150714T123646_R019_V20150704T102427_20150704T102427) using both SNAP beta version and s2tbx1.0, windows 64 bit version.

When I try ‘open product’ with the file I am getting a ‘No appropriate reader found’ error.
When I try import raster data -> multispectral data -> sentinel 2 MSI L1C with the S2A_OPER_MTD_SAFL1C_PDMC_20150714T123646_R019_V20150704T102427_20150704T102427.xml file, I get : An exception occurred: Type java.lang.NullPointerException No message text available.

Do the toolboxes support the S-2 data product yet? Or perhaps this sample data is a non-standard format?



Hi Jenny, please attach the latest log file located at ${USER_HOME}/.snap/var/log. It should contain the full stack trace. Thanks!

Hi Forman, I’m sorry but I don’t see how to attach a file to a post :confused: Should I just paste it?

Oh, I just opened it with the SNAP import -> optical data -> sentinel 2 -> L1B function but while there is a quicklook image, I don’t see data in the main window (same for all bands)

I see. This forum doesn’t seem to support attachments. Please send the log file via mail to


HI, I just sent the file to your email address. I would think lacking capability to attach files in the forum would count as a bug in itself :wink: !

The forum now supports file attachments !

Products acquired the 14th of July should not show any error, but I don’t have this specific one at hand for now. I’ll try to get it and report here.

Hi Jenny,

I fell you are using an old version of SNAP/S2TBX.
You can download the latest version from there :

Hello Malik, I uninstalled my version of snap (which I downloaded on Monday) and reinstalled from the website. The ‘About’ function gives me this version info: SNAP 201411181905.
I still can’t open the file using ‘Open product’, and get the same result as before using “import sentinel 2 data” (see 4th post in this thread), though I can now see only bands 2,3,4 and 8.

Hi Jenni,
There will be a new 2.0 Beta 5 release available later today.

Hi guys,

great, I can now read in the S2 L1C product with the new SNAP version. I guess more utilities will be forthcoming as commissioning progresses, like a L1->L2 feature? A quick RGB image facility would be great in the meantime. What is the best way to get information on new s2tbx features/versions without getting notifications every time someone posts on here?

Just one thing, which may be related to the product processing rather than the toolbox, the B10 data don’t seem to make any sense and consist mainly of NAN.

Thanks for your help,


Dear Jenny,

regarding staying up to date:

You could only watch the blog category in this forum. Then you will be informed about any news and will not receive email about all other questions. There is also a news feed on the main page.


Hi Jenny,

Great ! Thanks for reporting.

L2A generation from L1C is done by the Sen2Cor software, for which the S2TBX provides an adapter.
You can look in the help and search for Sen2Cor for preliminary instructions which will be updated soon.

You can open an RGB composite by right-clicking on the product node. You will then be asked for which bands to put in R, G and B channel, but a predefined set is provided for S2 to produce natural color images. Depending on the product, you may however need to play with the color manipulation settings to produce a good looking RGB composite.

To get information on new features/releases, the best is to get notification from the “blog” category : go to the category page then in the upper right section, set the circle to “Watching”. You will then receive an email for each new post in the blog category.

For the B10 issue, you can right click on the band in the product explorer and set its properties. The valid expression is B10.raw>1 and I fixed that just after the beta5 release to B10.raw>0. Actually the band data are full of 0 and 1. You can modify with the valid expression yourself to explore the data.

1 Like

Hi Jenny

Could you share the link of the sample file with me please?

Many thanks with best wishes'a04ba2a6-352d-4b32-a5a8-367ede20ccbf')/$value

The compressed file can not open. Uncompressed it opens.

Hi all,

I cannot open the product with S-2 Toolbox in Linux. I have tried different ways and it always throws a Java exception. Any suggestion please on how to open it?

Hi Carlos,

You can open the product with the latest beta version 2.0-beta5.
Give as input the main xml file present in the SAFE directory.

OK, thank you jmalik.

I can open the image, but I have a problem, when visualizing the bands I only get NaN for the pixels values. Does anyone have the same problem?

I have exactly the same problem. I got my SNAP installed today (Aug.3.2015). I so hoped, that SNAP would be able to open it (after none of the toolboxes could).