Can't resolve error message from GNDVI Processor

Good morning,
Using SNAP 8 Ubuntu, 16gb memory. I have a S2A image and I am trying to create a GNDVI Image but this is the error I get. Have spent hours on the internet and read all the tutorials but nothing helps.
What am I doing wrong?

Hi nrmadden,

The error message is a bit misleading.
If you resample the S2 MSI data product first to a common resolution then it should work. This is necessary because the data consists of multiple resolutions (10m, 20m, 60m). You can either use the general Resampling (Raster / Geometric) or the S2 Resampling (Optical / Geometric).

@oana_hogoiu Can you check this and improve the message?

Actually, the message is not misleading, it is as intended.

For any radiometric index that requires bands with different sizes, a resampling should be made.
In such situation, if you go to the Processing Parameters tab, you will see that the dropdown “Resample Type” is enabled with an initial value ‘None’:
That is because the module cannot make the choice on the user’s behalf on how to resample (downscale or upscale).
Therefore, you just need to choose one of the two methods.



Hi Cosmin, ah okay. This can be selected directly in the processor. I didn’t know. Then the message is correct, sure.

Good morning,
Thank you. Your prompt reply solved the problem. Is there a set of tutorials for V8. A lot of the online tutorials refer to earlier versions while V8 has a lot more options and processes available.
Neville in Australia

Hello to other side of the globe from Hamburg, Germany.
No, the tutorials have not been updated. This would be a lot of work to do it for every release.
I think most of them are still applicable and the general usage of the tools are still well explained.
If you miss something in particular or see where something is wrong, let us know.
We can then put it on the list of todos.