Configuring Snappy, GDAL, and pyroSAR

Hello everyone! I’m hoping I can get some advice for setting up snappy, GDAL, and pyroSAR in python. I’ve spent a lot of time trying to figure out how to install all three in python but it seems like there are conflicts and I don’t know how to resolve them.

I understand from the documentation (and from trial and error) that snappy is only compatible with python 2.7, 3.3, and 3.4 (although I’ve heard others have run it in python 3.6 and 3.7). What is the best way to run these versions of python? Conda virtual environments currently only support 2.7 and 3.5+.

How do you install GDAL and pyroSAR in these versions of python?

I’ve tried
python -m pip install pyroSAR
conda install -c conda-forge gdal
but if the packages are able to be installed, they return error messages

ex. pyroSAR in python 2.7 virtual environment
ERROR: ipython 5.8.0 has requirement prompt-toolkit<2.0.0,>=1.0.4, but you’ll have prompt-toolkit 2.0.10 which is incompatible.
ERROR: jupyter-console 5.2.0 has requirement prompt-toolkit<2.0.0,>=1.0.0, but you’ll have prompt-toolkit 2.0.10 which is incompatible.

Hello Everyone,

After lots of trial and error, these are my notes for setting up SNAP, pyroSAR, snappy, and GDAL.

Software Compatibility.docx (1.1 MB)

1 Like