Corrupt JP2

we noticed that several products, published today, have erroneous data.


has corrupted B02.jp2

That is probably a download-problem, please try again.

Note that ZIP file unzips OK, only (some) JP2s are corrupt. So it is probably not a download problem.
(we tried it several times for several products).

This is something you should report to the Copernicus Helpdesk.

Have you tried a different tools for unzipping the data. Some users had
trouble with certain tools.
I heard 7Zip should work well.

We did have problems with unzipping, but we solved those few weeks ago. And it was working OK until the last SciHub interruption.
We are pretty certain that the problems are in the content this time…

@mengdahl: I sent to Heldpesk, thanks.

Hi Grega,

Can you be more specific? Which bands are you having issues with?



In this case, the problematic one was B02.jp2 channel. The file is full of “0” (and nothing else).

Just to clarify - the B02.jp2 is second band.
So file is <product_name>_B02.jp2

To be as specific as possible.
Band: B02.jp2

We found problems also in same product in tile
43SCR (B05.jp2)

Hi Grega,
Here’s a screenshot of the two Tiles you mention taken in QGIS:

It appears your ROI has a lot of cloud!

That is indeed strange. We would like to understand, what is the reason we are getting erroneous data.
Would you mind sharing with us, from which Hub you have taken the data (we used Scientific Hub).
Also, could you send us the md5 hash of the product (; we have 8d6d5896d94e511d33c2170dd6b256f2)

We have re-downloaded the product at this moment, successfully unzipped (using 7zip) it and S2A_OPER_MSI_L1C_TL_SGS__20160122T093656_A003048_T43SBR_B02.jp2 has (still) only a lot of 0. inside. It is impossible to open it (tried several apps).

I had these errors of single bands with 0 KB some time ago. I changed the unzipping tool from 7zip to win.rar and everything works fine. Of course, if you have interrupts in your download (doesn´t matter if sci-hub, s2-hub, api-hub…), some parts of your zip-file might be corrupted.


HI Grega,

I used the SciHub product you specified, and used win.rar to extract it. This is the Band 5 in SNAP on my Windows 64 machine:

Jan, thanks for your support.
I now probably appear annoying, but I would really like to solve this issue.
We have tried and opened the zip with WinRar now (and previously with 3 others unzip applications on Win and OSX) and the problems remain:
In tile 43SBR, bands 2,3,4 and 8 are corrupted
in Tile 43SCR band 4 is corrupted (I have misspelled above, saying it is band 5, sorry about that)

We can (probably due to reasons above) not even open the product with S2TBX.

It appears to be an individual problem for now (only this product in January). So if we cannot find a solution, we will have to live without it. But would be nice to know…

Hi Grega,

No worries. I thought I had cracked it when I saw the Band 5 image. I’ll look into it further.



S2 MPC Operations Manager