DEM Assisted Coregistration with XCorr

I’m trying to coregister a TSX stack of SLCs using the DEM Assisted Coregistration with XCorr feature. However, I’m getting the following error message right after loading the images.

I’ve just built the master branch. Here are the commit hashes:

  • s1tbx SHA a80aa329
  • snap-desktop SHA 391b06e7
  • snap-engine SHA 307a5abb
  • snap-installer SHA 4f029bd8

Would you have any pointers? Thanks!

It seems to happen with SLCs and not GRDs. We’ll look into it.

Any news on this?
Also the Fine Registration in section “corss-coregistration” is grayed out…

I am getting the same error, It was working before and now is doing it. Is there a particular reason

What are your input products and what are their band names? Are you trying to create a stack from another stack?

No, my images are just the IW2_VV, i and q bands.
I have IW images and I slipt them, then I applied orbit files, deburst, and now want to correlate. They are not a stack or anything. It was working before with the same data. It just stoped

It doesnt matter which 2 images I use. It says the same over and over

This error is very annoying. I have been using other images, installed and unistalled the software several times and the same error appears everytime I am trying to to this. I have also tried to make my own graphs and do it step by step, but the warp steps is the one causing the problem. The normal corregistration works, however my images are horribly co-registered, i use 2000 GCP and the residual reports give me only 4 and full of ceros.
Please I can see that this error is not new. What is the problem?

Did you got an answer for this problem? The same is happening to me.

Dear @lveci
I believe there most be a general proble with the wrap funcion. The normal corregistration process in not giving any resuls regarging RMS residuals. Is there any infomration on this?

Hi everyone,
I have a problem with DEM Assisted Coregistration with XCorr.
I work on two satellite imagery - Sentinel 1 SLC. My computer has 32 GB of RAM.
First, I did Radar-Split (IW 3, VV) and then Apply Orbit File.
When I go to the DEM Assisted Coregistration with XCorr tool, regardless of what parameters I choose, I get the following error (see figure).
I do not know what I’m doing wrong. Can anyone help me?


For S-1 TOPS-mode data you need to use a different coregistration-method - please consult the tutorials.

But I wanted to use this coregistartion to get better results.
In the case of S1 TOPOS, I can only use the S1 TOPOS Coregistration tool?