Disturbing diagnostic output in S1 toolbox

When using gpt of SNAP version 6.0.0, my Sentinel-1 pre-processing graphs worked as expected. After updating to the newest version of SNAP and Sentinel-1 toolbox, gpt fills the screen with some sort of diagnostic output:
x = 4900.0, y = 2744.0, lat = 63.07686596721361, lon = 29.021174522894118, iter = 1, x’ = 4900.173414230347, y’ = 2744.01251132079
x = 4920.0, y = 2744.0, lat = 63.077857562883075, lon = 29.03271750605734, iter = 1, x’ = 4920.016619682312, y’ = 2744.0134880974847
x = 4940.0, y = 2744.0, lat = 63.07884817322127, lon = 29.04426088598319, iter = 1, x’ = 4940.657133102417, y’ = 2744.0132962306343 …
I assume this output comes from operator Terrain-Correction.
Is this output intentional ? If so, is there a way to get rid of this useless (to me) diagnostic output ? In an interactive console, this type of output is no big harm but in a batch processing environment it makes log files practically unreadable.


It shouldn’t be there with the latest update

The diagnostic output indeed disappeared in S1tbx v 6.0.6. Now the problem is that my graph stopped working.F-TEP_S1PreProcDiagram
Null point exception, coming maybe from Terrain-Flattening:

at org.esa.s1tbx.sar.gpf.geometric.TerrainFlatteningOp.computeTileStack(TerrainFlatteningOp.java:483)
… 38 more
Caused by: java.lang.NullPointerException
at org.esa.s1tbx.sar.gpf.geometric.TerrainFlatteningOp.computeIlluminatedArea(TerrainFlatteningOp.java:1313)
at org.esa.s1tbx.sar.gpf.geometric.TerrainFlatteningOp.generateSimulatedImage(TerrainFlatteningOp.java:721)
… 39 more

Error: java.lang.NullPointerException

I tried to regenerate the graph (on my Windows-10 computer) and run it but no success so far with S1tbx version 6.0.7.


I meant the S1tbx on my Windows-10 comnputer is 6.0.6.

Could you provide the product name and attach the graph.

Maybe it’s unrelated to your problem but, you shouldn’t multilook before calibration.

The graph (the one that worked yesterday with S1tbx 6.0.5) is:
S1mosPreprocessExt20180118.xml (5.6 KB)
The image product was: S1B_IW_GRDH_1SDV_20170902T154015_20170902T154040_007215_00CB7C_BF5F.zip

The DEM file was in the format that at least used to be accepted by SNAP: Plate Carre projection, pixel dimension the same in latitude and longitude, in GeoTiff format.


PS. Also multilook before calibration worked with S1tbx 6.0.5.

Making multillook before calibration did not change anything.