Empty images after calibration and SAR-Sim Terrain Correction


I try to use the graph processing tool (or batch processing) to preprocess S1-L1-GRD data.
My graph includes Calibration -> SAR-Simulation -> Cross-Correlation -> SAR-Sim-Terrain-Correction.

My problem is that it works perfectly for some images while empty images are returned for other scenes (to me it seems quite random).

Does anyone have similar problems or any idea what could be the reason for this behaviour?

Note: I work with SNAP 6.0 now and the processing already worked fine last year with SNAP 5.
Also it does not seem to affect particular scenes. When I tried to process a scene which resulted in empty output separately manually with SNAP (using the same graph), it worked…


Is the dem available for the area? Is so, does the coregistration fail? If the shift between the simulated and sar images is large then you could try larger windows.

Thank you for your reply! Yes, the DEM is available. Also, if I process one single scene separately in SNAP GUI using “Graph Builder” it works even for images which failed using “Batch Processing” or gpt.