Error "Apply EGM"

I think that i found a mistake in Range Doppler Terrain Correction module, when using EXTERNAL DEM check mark “Apply EGM” is’t working correctly.
By default if check mark “Apply EGM” TURN OFF in parameteres it has value TRUE.