Error in installing stand alone version of Sen2Cor in Windows 8

Dear all,
I tried for several hours to solve some issues in installing the new version of stand-alone Sen2cor 2.4.0 under windows.
The main problem solved already I had it was to uninstall anaconda 4.0 and to set path to my previous version of python.
Then I set the path in environments where the folder sen2cor is located and the command L2A_process --help worked from different locations in my machine.
At last, in trying to use the tools on real data I got the following error:

N:>L2A_Process --resolution 60 D:\sent2\S2A_MSIL1C_20170802T101031_N0205_R022_T33TVN_20170802T101051\S2A_MSIL1C_20170802T101031_N0205_R022_T33TVN_20170802T101051.SAFE
Traceback (most recent call last):
File “D:\Sen2Cor-2.4.0-win64\Lib\site-packages\sen2cor\”, line 355, in
File “D:\Sen2Cor-2.4.0-win64\Lib\site-packages\sen2cor\”, line 171, in main
File “D:\Sen2Cor-2.4.0-win64\Lib\site-packages\sen2cor\”, line 3415, in setSchemes
self.logger.fatal('wrong identifier for xml structure: ’ + product)
AttributeError: ‘NoneType’ object has no attribute ‘fatal’

Anyone faced the same problem on the forum? And any Idea on how to solve it?

PS I tried the new version stand-alon in ubuntu 14 and it worked like a sharme…