Error jvm installing SNAP on ubuntu 14

I tried to install SNAP on ubuntu 14 and got this error:

The architecture or bitness (32/64) of the bundled JVM might not match your machine.

I downloaded file from this link and run in ubuntu:
http://betatest:LQeGxx@step.esa.int/downloads/2.0/installers/esa-snap_unix_2_0-latest.sh

I thought it should be the right version for both 32 and 64bit.
I’m on 32bit machine.

JVM is installed:

java version “1.7.0_79”
Java™ SE Runtime Environment (build 1.7.0_79-b15)
Java HotSpot™ Server VM (build 24.79-b02, mixed mode)

Thanks

This version is only for 64 bit system. We do not offer a 32 bit installer.

Good afternoon, I hope I’m not wrong to bring this back up to life, but I’m currently in need to find a way to install SNAP on Unix 32-bit (not just one machine) for educational purposes. We have been given some “new old laptops” that run just fine. Could you please help? Can SNAP be built from sources? Thanks in advance.

Yes snap can be built from sources but in your case I would suggest to go another way.

Install SNAP on a 64bit system. Then replace the jre folder with a jre folder of a 32bit java installation.
Then copy the whole installation folder to the 32bit systems.
Maybe just removing the jre folder will work and you will be asked if the system jre shall be used. But I’m not sure.

Good morning, thank you @marpet, I’ll give that a shot and let you know how it went.
Have a great sunday.