Error NullPointerException when using GPT


I am encountering errors when executing graphs to process Sentinel-1 imagery using the GPT after the last SNAP update. I get a NullPointerException for different graphs I tested, including some that have worked before.

The messaging looks as follows:
SEVERE: org.esa.snap.core.gpf.internal.OperatorSpiRegistryImpl: org.esa.snap.productlibrary.gpf.FindImagePairOp$Spi:Find-Image-Pair conflicts with org.esa.s1tbx.fex.gpf.FindImagePairOp$Spi:Find-Image-Pair
INFO: org.esa.snap.core.gpf.operators.tooladapter.ToolAdapterIO: Initializing external tool adapters
INFO: org.esa.snap.core.util.EngineVersionCheckActivator: Please check regularly for new updates for the best SNAP experience.
Executing processing graph
INFO: org.hsqldb.persist.Logger: dataFileCache open start

Error: [NodeId: SliceAssembly] java.lang.NullPointerException[S1-preprocessing-single-beforeSA.xml|attachment]

Attached are two graphs I am trying to execute.

Thanks in advance!

(upload://tn4lyih9z2pWM4KKZEKWQgDJJ2R.xml) (1.7 KB) S1-preprocessing-single-SA.xml (1.4 KB)

I’ve found that order matters, try rearranging your nodes so that they are in order.

The graph should be in the following sequences of operators, to apply SliceAssembly

Thanks for the suggestion. I tried that but unfortunately the error keeps occurring.

I am working with GRD products so I don’t think I need to apply TOPSAR-Split. I have two GRD scenes that I would like to stitch since my ROI is on the boundary between 2 slices.

Your first post referred to TOPSAR-Slice assembly and this was the inappropriate graph you shared,

Thus, I gave you the right graph of implementing this process, in this post, Source of the post

In this case, you could,

Apply orbit for each tile, ---->then Apply from Radar tab, SAR Mosaic,