Error when I run stamps (6,6)

the following error appears when I run stamps (6,6) in SBAS folder, could anyone help, please? by the way I could not apply stamps(1,4) in some of the PATCHs as it contains NaN or 0. do this make the following error in stamps (6,6).
Error using sb_invert_uw (line 95)
There are isolated subsets (cannot be inverted w.r.t. master)

Error in stamps (line 505)

I also encountered this problem. Have you solved it?
If you can, can you teach me?

I expect it means that your small baseline network is not connected enough. If you plot the baselines ( sb_baseline_plot command probably) all of the dots should be connected together by the lines (the lines represent interferograms) but in yours you probably have separate groups of dots that aren’t connected?
If this is the problem then you need more interferograms to connect them up. The StaMPS manual has some information

1 Like

Hi Dear @eaeo
This is my plot, do I need to add more interferograms?

Yes, if you are getting the “isolated subsets” error I think that your red lines do not represent interferograms, only your blue lines. If so you have three separate subsets so you need to connect them much more. The start of Chapter 5 of the StaMPS manual has some suggestions.

Thanks for your answer.
Fortunately, I managed to finish all steps successfully. But there is a question, how can I set these parameters? What is the command used to change these parameters?

Please have a look at page 19 of the StaMPS manual.

Hi dear @ABraun
Actually, I checked the StaMPS manual command and used setparm(‘param name’,param value). But it is not working on the sb_parms_initial list, it only works on getparm list.

What exactly did you enter?

I want to change/set these parameters for SBAS:

  1. setparm (‘scla_deramp’, ‘y’)
  2. setparm (‘weed_neighbours’, ‘y’)
  3. setparm (‘unwrap_hold_good_values’, ‘y’)
  4. setparm (‘plot_scatterer_size’, 70)
  5. setparm(‘ref_centre_lonlat’, [49.357558 36.766223])

I notice two things that might cause errors

  • there should be no space between setparm and the open bracket
  • maybe you use the false quotation marks. These should be the straight ones, not the curly ones.
setparm (‘scla_deramp’, ‘y’)
setparm ('scla_deramp', 'y')

Thanks for your quick response.
It is not the problem I think, because when I use the command it successfully works. But when I check the parameters again are set to default.
Screenshot from 2022-04-24 13-10-39

sb_parms_initial sets the parameters to the default values when stamps is first set up
setparm lets you change parameters
getparm tells you what the values of the parameters are now

so you don’t need to run sb_parms_initial after you run setparm.


Good one, @eaeo I did not not notice that.

1 Like

Thank you @eaeo @ABraun it works now.