Export reflectance to GeoTIFF


I´m using Snap to work on Sentinel 2 data.
First I imported the data, then I created the Sentinel-2 Level 2A product with athmospheric correction, resampled the data and made a subset of one region. Now I have hopefully correct reflectance values in Snap.
My next step is to export the data to GeoTIFF, but when I open it in another programm (QGIS, R, ENVI), I have wrong values. The initial values prior to the export are between 0 and 1, but my output values are round about between 500 and 6000. I don´t see any pattern like a wrong dimension. First I thought there is a problem with the data type, but I tried all options in the convert datatyp window and had always the same result.
What could be the problem? Snap is updated to the newest version, I work on Windows 10 64 bit.

Thank you!

You need to apply the scaling factor.
In Geotiff the data is stored without the scaling factor applied.
I assume it is the same after AC as before. So you need to divide all values by 1000.
But you can double check this scaling factor in SNAP.
Select one band and open from the menu Analysis / Information. There the scaling factor and also the scaling offset is shown.

1 Like