External DEM: Working in DEM-Assisted Co-registration but not topographic phase removal

I should start by saying that I know there are similar posts on this forum addressing this problem, but they are quite old and there has not been a full solution.

I am working with some TerraSAR-X data in the Andes. I have a DEM derived from GeoEYE imagery (1 metre but resampled to 5 M) which covers the portion of the TSX data I am interested in. I am able to do a DEM-assisted co-registration using this DEM and get the following phase patterns

but when I try to do topographic phase removal I run into problems. The simulated topographic phase and elevation band are not added into the stack, and the phase patterns look the same as before the topographic phase removal:

When I use the SRTM (either auto-downloaded, or downloaded and used as an external DEM) the topographic phase removal works:

Based on answers I have found on this forum I have tried re projecting my DEM to WGS1984, re sampling it to a lower resolution, and reducing the bit depth, but without success.

It would be a shame to be stuck with the SRTM when I have a higher-resolution DEM, so any help would be appreciated!