Fail coregistration

Hello forum,
I’m a relative new user and I’ve been procesing images in order to compare two images of different periods of time. The problem is that it depends on the place of study, the slave radar imagen doesnt exist, (when coregistration is done (ERS)).
I’ve tried to change in cross correlation the number of GCP, size of windows, tolerance,… and, on wrap, I tried to change polynomial order and interpolation method, but the pixel info of slave product always has appeared like NaN.
I’ve also tried with Sentinel 1 images in the same place. For that, I used an external DEM for back geocoding (cos it is needed), but the processed product of slave image doesnt have information.
I always follow the same steps, depend on the type of product(ERS or S1)…
In addition, I have done the subsets in a precise and a careful way, apply the orbit file, but I cannot continue with the flattened inteferogram generation as the slave product fail

Thank you for any suggestions and advice

are both images of the same track/orbit?
Maybe one is ascending and the other is descending?

Both has the same relative orbit and descending, and it’s possible to create a stack with both, but,as i have said before, it’s not possible to make correctly all the coregistration (it fails in cross correlation or wrap)
One is from ERS1 while the second is from ERS2, however it is possible to work with images from both satellites, i’ve done it before and i’ve read some reseach where it is done.

I cannot upload the files here because it gives me an error

thanks for answering

this should technically work then. If you give me the location and dates of the scenes I can download them myself.

They are from deception island, dates: 1993 02 22 and 2010 03 04
Thanks for all

#Download of the images

Subset and Orbit file



Not perfect, but works technically and could be improved by a higher number of GCPs and adjusted window sizes.

The photos show the same that i have been doing these two weeks, but know it run perfectly.
Thanks for all

Hi ABraun, I need help again…
I’m trying to begin with SNAPHU (I have not used it before) with the two images about deception island, those about we talked last time.
So, apart from have aplied orbit file and coregistration, I have done an interferogram formation and a goldstein phase filtering. After that I’ve export to snaphu (unwrapping), but when I use the console, it gives me an error. I don’t know what is failing

thanks for all your help

are you operating the script in the same folder as the conf file?

This is the file that snaphu create when the unwrapping is done

This file is inside the file where i have processed the images

yes, so you need to start snaphu in exactly this folder, not in C:\users\alega
Otherwise snaphu doesn’t find the conf file