Failed scan for Tools descriptors: I/O problem

When I’m run gpt I got this messages:

WARNING: org.esa.snap.core.util.ServiceFinder: Can’t search for SPIs, not a directory: /Users/andrey/.snap/snap-python
INFO: org.esa.snap.core.gpf.operators.tooladapter.ToolAdapterIO: Loading external tools…
INFO: org.esa.snap.core.gpf.operators.tooladapter.ToolAdapterIO: Scanning for external tools adapters: /Applications/snap/java
SEVERE: org.esa.snap.core.gpf.operators.tooladapter.ToolAdapterIO: Failed scan for Tools descriptors: I/O problem: /Applications/snap/java

Is it ok? If not what can I do?

And one more question. Can I run GPT in multiple processes(like in two tabs in terminal)?

That’s ok. Actually not, this directory shouldn’t be scanned for tool adapters. It is fixed in a future release.

Yes, gpt should work when invoked in parallel.


I’m seeing (on linux) the same error (both the ~/.snap/snap-python warning, and the snap-install/java severe tool scan i/o problem) in the most current version (5.0.0 with all updates applied), and during install I selected not to configure for python.

Thanks, 5.0.4 seems to resolve this issue (tool adapter only mentioned in an info message, python/SPI/servicefinder not mentioned).