Glitchy radar radiometric calibration interface within graph builder

When I run the Calibration tool (Radar->Radiometric->Calibrate) inside a graph builder it sometimes shows the correct set of processing parameters (output as sigma0, gamma0, or beta0), and other times shows what appears to be an older version with “save as complex output” an option, along with gamma0 and beta0 outputs being virtual bands. It also has a mention of ENVISAT, which is why I think it’s older. Even when I select the beta0 virtual band output it errors for later steps saying it doesn’t have the proper input (when a normal beta0 band should be the correct input).

I do not know what causes one set or the other of these to show up. After I noticed the ENIVSAT version I tried deleting the later tools in the graph and then adding them back in one at a time, and some how along the way the calibration parameters changed to the correct set of options. I have yet to be able to recreate the switch to showing the ENVISAT version.

This is the same problems as mentioned here: this summer. I am running SNAP 4.0 (SNAP Desktop 4.1.0 and S1TBX 4.0.4) on Windows 7.

1 Like

Try with the current version 5.0 (+updates)

I am having the same problem even though my software is up to date - does anyone have any solution ?