GPT gdal dll load error


#1

I’m trying to use the GPT in the command line but keep running into this error that stops GPT from starting up

I have 64 bit SNAP running on a 64 bit Windows, with 64 bit python in the environment variable, so I can’t think of why gdal would be giving a Win32 error.

I know I’m probably missing something simple, but thanks in advance for any help


Gpt and GDAL throws an error
#2

GDAL needs to have its own Env variables one in the general “path” and extra variables called “GDAL_DATA” for …/GDAL/gdal-data and “GDAL_DRIVER” for …/GDAL/gdal-plugins.

Might be that, could be multiple GDAL instances on your PC.

Petr


#3

Adding the GDAL path variables didn’t seem to help, although in the SNAP command line when I type in gpt it gives the same errors as above but also shows “Error: Failed to initialize velocity engine” although I suspect that just is a result of gdal not being able to load

Also I don’t have gdal installed on my machine so there shouldn’t be multiple instances causing the issue

I appreciate the help though


#4

The message regarding the velocity engine is actually a false error. You can ignore it.
If you don’t have gdal installed there should be no error at all. I’ve informed the people who are responsible for the gdal integration.


#5

Hello @HenryJ, what SNAP version do you use?


#6

I’m using SNAP 6.0, I tried on another computer with a fresh install of SNAP 6.0 and I get the same error. However, a colleague using SNAP 5.0 doesn’t seem to have this issue.


#7

As it seems to be a SNAP 6 preview issue, I moved it into this category