Gpt Write bug (51.1 KB)

I am trying to write SNAP data to dim file format, but it lost some information.
gpt Write -Ssource=target.dim -Pfile=0__91CF -PformatName=‘BEAM-DIMAP’

I also try write this to GeoTIFF-BigTIFF format, but it takes very long time for saving this data.
gpt Write -Ssource=target.dim -Pfile=
0__91CF_without_gpt.tif (204.4 KB)

If I export using SNAP → Export → GeoTIFF/ BigTIFF, there with data is alright. In attachment add those dataset.

For the sake of completeness:

  • OS: Windows 11 x64
  • SNAP: V 9.0.3

Maybe somebody can help with this bug?

What information is lost when you write to BEAM-DIMAP?
Have you tried to use only ‘GeoTIFF’.
You could also try NetCDF4-CF format.
GeoTIFF-BigTiff can be slower because the data needs to be compressed.

1 Like

For this small picture gpt runs more than 1h but using SNAP Export ->GeoTIFF / BigTiff it takes some seconds. The difference is very large.
I try NETCDF4-CF it not can open in QGIS.

I also tried Geotif format. Using write function this save takes very long times.

I am trying to process S1 data using gpt. I used gpt for the read, apply orbit File, thermal noise removal, calibration, terrain correction, subset. And the last ist Write.

Before I run Write, I have image before use gpt command.

Then I used command Write from gpt tool

gpt Write -Ssource=D:/pysnap/08_toDb/target.dim -Pfile=0_S1A_IW_GRDH_1SDV_20220828T160434_20220828T160459_044755_055813_91CF -PformatName=‘BEAM-DIMAP’ -PclearCacheAfterRowWrite=false -PdeleteOutputOnFailure=true -PwriteEntireTileRows=true
INFO: org.esa.snap.core.gpf.operators.tooladapter.ToolAdapterIO: Initializing external tool adapters
INFO: org.esa.snap.core.util.EngineVersionCheckActivator: Please check regularly for new updates for the best SNAP experience.
INFO: org.hsqldb.persist.Logger: dataFileCache open start
Executing operator…
.13%.60%100%140% done.

Why there is done 140%?

The Dim picture after Write command in SNAP looks that

Why SNAP not show Dim file?