Graph Builder: TOPSAR Coreg Interferogram - Execution time?

Hello everybody,

In order to get interferograms of Sentinel-1 SLC data, I chose to use the GraphBuilder tool in the GUI of SNAP, rather than processing the data step-by-step. I used the xml graph “TOPSAR Coreg Interferogram”, as I only wanted to process 1 subswath. I started the process 3 days ago with 2 scenes and it is still running. After a few hours, the processing bar stopped at 24%, but the process is still running in the background (I checked the task manager).
Is this normal behaviour? How long is the expected run-time for Coregistration & Interferogram Formation?

Scenes used:

I use SNAP on Windows 10 with a Intel Core i7-4790 processor, 16GB RAM and a 250GB SSD.



everytime I use this graph, the process took between 110 - 140 minutes. ( and i use 8GB RAM and no SSD) So your process time is quite weird.

Hi @MatousK,

thanks for your reply. I just did a few more tests and I think I made out the source of the issue. The problem is probably related to the fact that I changed the ouput format from BEAM-DIMAP (default) to Gamma. When I process the steps individually (first Coregistration, then Interferogram Formation), I get an error, namley

Not able to write product file: ‘/data2/dgmk/Processing/Sentinel/66/20150526_20150514_Coreg.par’

in the coregsitration step.
After that, I let the output format for the coregistration on BEAM-DIMAP and only changed the output from the interferogram formation to Gamma. This error occured (basically the same as above):

I don’t quite understand why this error occurs. Did you try and change the output format for your interferograms?
Maybe this is a bug that still has to be fixed.



I’d like to recommend you to do cor---->deburst------>intefergram formation

also before inteferogram formation step you could subset your study area to decrease the processing time

Thank you for your reply.
I already solved the problem with the high processing time - it was due to the chosen export format Gamma, which does not work properly. With other export formats, such as BEAM-DIMAP or ENVI, the process takes an acceptable run time of about 2 hrs.

Dear Maryse and other collegues,
I am sorry to repeat again my problem with exporting results to Gamma but I still can not solve it. This problem has been already mentioned by other people (10 Febuary this year). Did you manage to export results for at least one pair of SLCs to Gamma format so that it can be used by mt_prep_gamma in STAMPS? I tried to do it using SNAP 2.0.2 in UBUNTU 14.04 12.04 and Windows 7 Both with 16 GB RAM. I tried to export the results of TOPS coregistration and Interferometry formation as well. But the error message was the same:

About reducing the execution time. From my experience to save time : after S1Tops corregistration Deburst -Subset can be done. In this case Interferogram formation is done only for your subset.

I will very much appreciate any advise

Dear Katherine,

I am currently facing the same problem as you, namely the export in Gamma format to use the products with mt_prep_gamma. I did not find a solution yet, i’m sorry. Maybe another colleague from the community can get us a hint on how to solve this?


Dear Maryse,
Thank you very much for your quick response! I am happy that I am not alone with my problem. Oh, if Iveci or somebody else from the community could help us!

I’ll look into this today. I suspect it’s something which goes wrong specificly on linux.

Thank you very much Iveci! I will be waiting for! Just to let you know that I had the same error when I tried SNAP 2.0.2 on Windows 7 (64bit)

Same here. I also tried to run it with SNAP 2.0. on my local machine with Windows 10, 64bit and it could not export in gamma format.
Thanks in advance!

Dear Luis,
I do understand that you are very busy with plenty of different problems and I am sorry to bother you but just to remind. Did you manage to find out what is wrong with using GammaProductWriter so that we can not export Snap results to Gamma format?
Thank you for all your hard work

Yes, the problem should be fixed in the next release available probably next week.

Thank you very much! We are looking forward for it!

Am having this problem am executing the interferogram formation. What could be the problem

Please help

Hi @mumina
The EAP phase correction was introduced by ESA in March 2015. So, if your data stack contains scenes from before (as in your case), you need to perform the correction manually. See also this link:

You find the tool for the EAP phase correction under Radar - Sentinel-1 TOPS - S-1 EAP Phase Correction and you need to perform it for every scene before April 2015 which takes a processing time of about 2 minutes per scene.

Hope this is helpful.

“Not able to write product file” by the coregistration. What was your solution to this one, Maryse?

Apparently that GRD format causes more problems than it solves.

Liebe Gruesse aus Thessaloniki.

This error usually means that you ran out of disk space.

1 Like

Dear falahfakhri
Plz tell me When to subset our study area?
I gives an error if i subset Intensity image at the start.