GraphBuilder fills up hard drive

We have been using GraphBuilder to convert a S2 image into a 4-band geotiff. The process works well for a while and then you find that the C:drive is filled to the brim and we cannot see what is taking up all the space. Any ideas?

This sounds related to this one:

Can you also tell a bit more how you configure the graph builder.
For example you can export the graph and attach it here.

Please see my answer in the other thread:

Hi Marpet,
Thanks for the prompt response. I have been waiting for my off-sider to return from a field trip before trying to sort this out.
We think the problem is Windows related and also to do with the default path for the cache. Is it possible to set the cache path so that it is not on the C:\ drive? We are using 250GB solid state drives and processing a S2 image with the graph (resampling to 10m band, subsetting to 4 bands, saving as a geotiff) was filling up the drive.
GeoTiff.xml (1.9 KB)
Our solution is to install SNAP on a larger disk drive which is not the ideal solution as performance is compromised.
We are unable to change the cache path from Tools/Performance - while a new path can be browsed to, the OK and Apply tabs remain greyed out. Do you have another solution?

Please have a look at this thread:

OK we can set the userdir but now we cannot change the cache size, it defaults to 1024 even though we have changed the value to one of the higher options (33792) in, Under the performance tab in Options the OK and Apply tabs are always greyed out.

The problem with the disabled button should be solved already. Maybe you need to update your SNAP installation.
I’m not sure at the moment, but I think the values in have precedence. By the way, you know that this cache size is not the cache on disk? I just ask to make it sure.

Updated from 5.0 to 5.0.2 and now it all works. Many thanks.
Cheers, Mike