How can Snap access the mechanical hard drive?

How can Snap access the mechanical hard drive? because my data is under the mechanical hard drive,but SNAP can’t use these mechanical hard drives, please help me ,thanks in advance


I guess you are using linux. It isn’t clear from your post exactly whuat happens when you try to access the drive. From the information you provide we can’t tell if the drive has failed, uses a filesystem that isn’t supported by linux, or is working but has permissions that block access by your user account. If other applications are able to view and load files, e.g., the problem is specific to SNAP, then we need to see more details. If other applications can access the drive, you will get better help from the forums for you linux version – those forums have many more participants with long experience with the linux version you are using.

Wherever you post, it will help to provide answers to the following questions:

Were data put on the drive using a different system or by a different user? Is the drive one of the devices (/dev/sdXX) shown in the second image? Do you get any error messages? Can you select the drive containing the files you want to use and see the folders? Can you navigate to the files you want to use? Can you select a file but it fails to open?

You may find it helpful to read the relevant sections of the The Linux Command Line book which has been translated to a number of languages.

The best way to explain the problem in online forums is to past text from a terminal session (images are often hard to read on laptop screens, and it is harder to copy a section of text to use in a response). It would help to see the line from the problem drive in the output of df -lhT | grep -v tmpfs, for example:

 % df -lhT | grep -v tmpfs
Filesystem                              Type      Size  Used Avail Use% Mounted on
/dev/mapper/fedora_localhost--live-root ext4       34G   19G   14G  57% /
/dev/nvme0n1p5                          ext4      976M  248M  662M  28% /boot
/dev/mapper/fedora_alt-home             ext4      151G   71G   73G  50% /home
/dev/mapper/fedora_localhost--live-opt  ext4       17G  3.5G   13G  22% /opt
/dev/mapper/fedora_alt-local            ext4       69G   27G   38G  42% /usr/local
/dev/nvme0n1p1                          vfat      646M   79M  568M  13% /boot/efi
/dev/sdb3                               xfs       3.5T  868G  2.7T  25% /Volumes/Data
/dev/sdb1                               fuseblk   2.0T  1.7G  2.0T   1% /Volumes/NTFS

This will tell us that the drive is mounted and which filesytem the drive uses. If you get this far, the next step is to check the filesystem for “corruption”, which depends on the type of filesystem, then examine file ownership and permissions.

1 Like

Thank you very much for your careful answer. My computer is a Linux system, but I installed a dual system (the other system is windows). When SNAP selects files, it can only choose the Linux file system (ext4), and other mounts The hard disk (type fuseblk) cannot be accessed. I tried to underline a disk partition (type ext4) under Linux, but snap can only access that disk (“计算机” in the figure)

I also have systems with both Windows and linux, but generally I use linux. When
windows fails, I have used linux to recover data preparatory to reinstalling Windows. fuseblk is the standard linux user mode mount of NTFS filesystems. I just tried SNAP with files on the NTFS filesystem, and had no issue reading a test NetCDF4-CF format file with SNAP.

When I mount the Windows partition using the file manager, I get a prompt asking for my linux password, and the partition is mounted to
/run/media/<linux_username>/<drive_label>/ (you can find this from the output of df -lhT | grep -v tmpfs or mount | grep <linux_username>). If you do ls -ld /run/media/<linux_username>/<drive_label>/ you should see drwxrwxrwx. permissions.

Have you checked to see if other programs can use files on the fuseblk filesystem?

There should be a way to mount the Windows partition to a location of your choice at boot time, but the details depend on your distribution. It is also possible that there is a bug in the support for your character set on your linux distribution. If you suspect that, you need to contact a forum dedicated to your distribution.