How to prepare Sentinel-1 images stack for PSI/SBAS in SNAP


#872

Oh, I hadn’t noticed this error.
I’m not very into the Linux operating system, so I’m going to understand what segmentation fault means; I hope I’ll be able to fix it. I’ll share my progress, if any.
Thanks for your fast replies :slight_smile:


#873

I used 30 images to Interferometry,and get 29 ifgs ,it should be 32 columns in the exported csv including(lon column,lat column,NA column and the 29 cumulation displacements columns),but actually there are only 28 cumulation displacement colums,anyone who meet the same question as me?


#874

I am having issues in plotting the StaMPS processed data. wherever i tried to plot {ps_plot (‘u’)} something it shows error.
it says “Could not check if this is envisat” and Index exceed matrix dimensions.
can anyone tell me whats the reason behind such errors.


#875

Please take a look at this might be it is helpful to you,


#876

Dear @falahfakhri I successfully completed the StaMPS steps using its 4.1b version. But when i tried to plot results it always shows error. I already follow the paper you uploaded but theris nothing in it related to “ps_plot”.


#877

Did you read this?


#878

Yes, i already read all the comments related to ps_plot, i also tried to edit code but failed.
can you please send me updated ps_plot.m file if possible.


#879

You can try to use the ps_plot function from previous version. I think it is something wrong in the last version one.

I hope this helps, as it does work for me that way.
Cheers


#880

Dear @mdelgado thanks for your comment.
I will try to use older version, and will let you know.


#881

Hi everyone,

I resolved the Segmentation Fault; I spot the line of the mt_prep_gamma_snap code that caused the error:

(line 145): calamp calamp.in $width $WORKDIR/calamp.out f 1 $maskfile

and I changed the value from 1 to 0:

calamp calamp.in $width $WORKDIR/calamp.out f 0 $maskfile

I don’t know if this was a good move, but at least the Segmentation Fault is resolved. Maybe this will help someone else will meet the same error.

The problem is that the pscands files are all empty. When I type stamps(1,1) in matlab, I have this error:

Anyone could help me? Thanks a lot


#882

Firstly, try to use the mt_prep_snap available in latest StaMPS release available here:https://github.com/dbekaert/stamps
Secondy, had you checked the produce interferograms?
If not please do. If you already checked that, I suggest you to use again latest StaMPS release as it filters out pixels which produce the out of bounds message as yours.

I hope this helps


#883

Had you tried already? Was that any better this time?


#884

i tried by replacing matlab folder of StaMPS, which i downloaded from here (esa forum). but the results were same.


#885

Dear mdelgado,

thanks for your answer.
I used the mt_prep_snap in the latest StaMPS realese as you suggested, but I got the same error.
I tried also to plot interferograms with plot_all_ifg.m but nothing; I’m wondering that the problem is related to the pscands files that are all empty. Moreover, the mean amplitude value is inf, during mt_prep_snap execution:

Any idea to how fix the problem with pscands files?
Do you think is a problem with Snap export files?

All the best,
Marco


#886

Actually the visual interpretation of the interferograms or resampled slaves was what I have meant. plot_ifgs.m will not work anyway is pscands is empty.

The reason of the empty pscands can lay on the wrong or corrupted slaves or ifgs.
In case that they are wrong or corrupted (I am seeing many mean amplitude 0 and Inf values that you should check), you should process them again.

Please check


#887

I’m wondering that probably I made a mistake in my workflow chain in SNAP :

  1. master_stack (after split and orbit)
    2)master_stack_deb
    3)subset_master_stack_deb
    4)subset_master_stack_ifg
    5)subset_master_stack_ifg_dinsar
    then I exported the 3 and 5 to stamps to obtain the 4 directories
    Maybe also stack_ifg should be first debursted

Thanks a lot for your time


#888

From the log list of rslc…
Can you please open the first 2 ??
In such way we can conclude that the error itself is not mt_prep_snap, but the processed data (what I think it is obvious at this point…)

Good luck!


#889

Do you mean this folder?


#890

I meant to open one of the files, or the rslc, and also their correspondents dim files (before stamps export), using SNAP to understand it they are empty files


#891

Ok, I’ll check if everything is ok before stamps export.

Thanks a lot : ')