I get error message every time I try to compute LAI and FPAR using S2A-MSI-L1C

HI All,
I am trying to compute biophysical properties using S2AMSIL1C data in SNAP using 11 bands, but each time I try doing it, it says bands do not have same spatial pixel size and when I tried after resampling all bands to 20 m, I get the same error. Any suggestion or help would be highly appreciated.


Are you using the subset operator before computing the biophysical processor? I think that your problem could be related to an issue with the subsetting of some masks: https://senbox.atlassian.net/projects/SNAP/issues/SNAP-686

Until the problem is fixed, the workaround is to read the S2 image without the masks (Tools-> Options->S2TBX-> “Sentinel-2 Reader Masks” and uncheck all the masks).

Thank you Omar, I will give e try to the workaround solution that you have suggested.

Hi Omar,
I got the same error again,


does your input product contain any mask?

No masks, and in fact I unchecked all masks prior to resampling but still I cannot do biophysical index calculations.


I don’t know what could be the problem… What version of SNAP are you using? Which is your input product?
When I open a L1C product, resample it using as reference band a band at 20 m and after that I apply the biophysical processor it is working properly… Also if I apply a subset after the resampling. Are you doing the same steps?

I just looked at the version it says V 4.0. my input file is a folder that I unzipped after I download from the copernicus website to download Sentinel 2 data.
I tried all three option when I resampled it, using 20 m, 10 m and 60 m but nothing works.

Is the version I am using latest?

No, the latest version is 5.0. Please, could you try to download it, update all the modules and try the process again?