Import of COSMO SkyMed fails


I tried to import COSMO SkyMed data via the “Import” menu, but the import is impossible. After selecting the corresponding .h5 file, the toolbox pretends to start loading the data, but even after 30 minutes nothing happend. I’ve tried several times and even on another installation, but I always encountered the same problem.

Is this a known issue or does anybody have a solution to fix it?

Best regards

I have just tried to open a CSK HI DGM image on SNAP 2.0-beta-06, and it works well.

When you open the image, can you see anything on the “Product Explorer” panel on the left?
Can you open CSK images using some other software on that PC?

SNAP is working out, thank you. Previously, I was trying to read the data with ST1TXB (Version 1.1.0), which did not work out.


The similar problems happened when i imported the cosmoskymed single look complex slant range (SCS) product. Only the QLK band was listed in the left of SNAP. The i and q channel was missing. So, I can’t continue to do the next processing such as coregistering and geo-correction.
Is there good solutions to my problem? the software version 5.0.8 and 6.0 beta.