Installing Sen2Res from command line


I’m trying to install Sen2Res plugin in a SNAP instance that is running in a virtual Linux environment. I can access it only via command line, and I’m having some problems. It doesn’t show up in all available modules list, and when I try to install it through .nbm file, I get “Cannot install. No match for [/sen2res-1.1.nbm]” error.

Any ideas how to make it work?

Is there a SNAP installation that also has a GUI available?

Do you refer to Tools → Plugins → Available Plugins?
If yes, please attach a screenshot with that you see there, plus Tools->Plugins-Settings.
Thank you.

Unfortunately, I can’t access GUI. I can interact with SNAP only via command line.

I was referring to a list of modules that appears after using “snap --nosplash --nogui --modules --list --refresh” command from here:

I can see modules like Sen2Cor or Sen2Coral on the list, but Sen2Res is absent.

Which version of SNAP?
(Sen2Res 1.1 was only deployed for SNAP 9 on the update center)

I’m on SNAP 8, so I guess that’s the answer. Due to constraints of my project, I can’t upgrade to SNAP 9.

Is Sen2Res 1.0 still available to download somewhere, or the only way to use it now is to upgrade SNAP?

You can find both versions:
I think sen2res 1.1 should also work with SNAP 8 (just that we only saw this newer version after SNAP 9 release, this is why it was deployed only in SNAP 9 update center)

1 Like

Okay, thank you for the links!

I’m using the installation command: “snap --nosplash --nogui --modules --install ”, and sadly, I’m still getting the error message: “Cannot install. No match for [/sen2res-1.0.nbm]”.

I’ve tried several different ways of inputing the path, and none of them worked. The file sits just in my main folder, so I think it should be either “sen2res-1.0.nbm” or “/sen2res-1.0.nbm”.

Maybe it’s related with

Here I see that:
“It seems that this error message is simply wrong and the installation works.”

I would not expect either of those file specifiers work. Did you try using the full path: <your_main_folder>/sen2res-1.0.nbm?

I don’t think that’s the case, since I still can’t see Sen2Res in the modules list nor in GPT.

It’s actually inside a container, so I believe if a file is in the main folder, the path is just like “/file.txt”. It works like that in other instances, and also when commands like pwd or ls are used.

be aware that the plugin does not work properly since ESA alter the folder structure and distribution of S2 data and the developer is not yet active to make the proper alterations to the plugin.