Is it possible to perform coregistration on subsets of SAR datasets?


I’m trying to make an interferogram from two ERS images, however the coregistration is taking a long time because I need to use a very large number of GCPs. I tried using subsets of the two images to speed things up, but I was unable to add them to the table in the coregistration window. I was wondering if it is not possible to coregister (and ultimately generate an interferogram from) subsetted SAR data?

Many thanks!

You have to right click the subset dataset in the product explorer window and save it first, then they can be coregistered.

I doubt that it’s really possible. There are some steps after the Coregistration and such steps like the Terrain correction cannot be made on the subsetted image :frowning:

If you applied orbit files on your raw data I see no problem in subsetting them and using the subsets for coregistration.
And you can also perform Terrain Correction on your coregistered stack as well.

Hi All,
Thanks for getting back to me, I applied orbit files before subsetting, and I managed to run the coregistering tools on the subsets (after saving them), but I never got as far as making interferograms or applying topographic corrections because the results were strange - this was the best I was able to get using DEM assisted coregistration with XCOR:

But I’m having coregistration problems with full images as well, which I’m trying to solve in another question on this forum.

yes, your screenshot indicates that coregistration wasn’t successful. Despite of the processing time, did you try coregistering the whole images (after orbit file application)? This increases the chance that matching registration points are found.

Here’s an example coregistering the full images (after orbit files applied), with default options (standard coreg. not DEM assisted), except number of GCPs increased to 20,000:

The two original files are:

Hard to tell from the screenshot but doesn’t look correct.
How many GCPs remained? A txt file should have popped up which shows the reduction of valid GCPs.

I don’t remember seeing that information - is the txt file saved somewhere, or do I need to run the coregistration again?

I ran the coregistration again, and the only information that appears is:

Processing completed in 46.233334 minutes (629426 B/s 209808 Pixels/s)

you have to check “plot residuals”

I think the problem could be the data - the latter image was acquired with ERS-2 in Zero Gyro Mode (ZGM) with degraded pointing accuracy, see this PDF for info:

1 Like

Use Coregistration operator instead of DEM Assisted Coregistration. Also use 256 or 512 for “Coarse Window Width” and “Coarse Window Height”. See if it helps.

Thanks for your help, I wasn’t aware of the doppler frequency problem. The difference for the two images I used above is -1380.45Hz (with Bperp of -57.28). I tried coregsitering two images with a much smaller fdc of 85.80 Hz (but a large Bperp of -1014), and the results look a lot better:

Zooming on the mountain in the center:

1 Like

Do you mean ‘show residuals’ on the warp tab of the coregistration window? I’ve tried checking that, but I don’t get any pop up window / text file when it finishes. (I’ve tried this on both snap 5 on Linux and snap 6 preview 4 on windows). Sorry if I’m missing something obvious here!

yes, I meant this checkbox. Actually, a txt file should appear during the process.

Does one of those help?

Yes, thanks for the links! (For anyone else, I found the GCPS by opening view->tool windows-> radar-> InSAR stack, selecting the stack file in the product explorer and selecting coregistration residuals in the tool window. Note for some reason, if the stack file is expanded in the product explorer it doesn’t seem to recognise it as a stack file and won’t show the residuals, at least on snap 5.0 on linux).

For the successful coregistration with the low doppler frequency difference, I get 122 GCPs and the following statistics:

Does this seem reasonable?

122 are not much but should be sufficient. I however downloaded your data and didn’t get a proper coregistration as well. :frowning:

Thanks for having a look! I guess I just have to be more careful choosing ERS pairs to keep the fdc difference low. Going back to the original question, I tried coregistering a subset of the low fdc pair and that worked as well.

Many thanks for your help!