Issues/Observations/Comments of SNAP 6.0 Beta


#1

Please post your experiences in this thread.


Can´t open Sentinel 2 file
After tiling views - one is lost
Workflow between SNAP and StaMPS
Cross insar ERS-ENVISAT range filter
#2

hello Mengdahl,
I experienced with the SANP version 6 beta the same error I add in the previuos version.
In case a differential interferogram is made between ERS2 and Envisat tandem mission (with image taken on the same day - the 16Jan2009 - just 30 minutes one after another) I experienced some difficulties in performing range and azimuth filtering with the following message received:
a problem occurred during the the target püroduct initialisation
message: the product “range filter” already contains a band with the name “Phase_16_Jan2009”
regards
buendia


#3

I’ve been using the new beta 6.0 for a little while now. I haven’t tried all the new functionality but things look stable. Good jobs guys!

Luis


#4

I have just tested Snap 6.0 beta version for check the problem with Topo Phase removal tool with stack. http://forum.step.esa.int/t/topographic-phase-removal-of-s-1-stack-for-stamps-export-has-some-problem/
All is ok now! Great job!
Thank you very much!


#5

SNAP 6 looks like it has some really useful features. Thank you to everyone involved!

I notice that the the issue of artefacts in Terrain Flattening has recently been marked as fixed. Is there any likelihood of this being integrated into the upcoming release?


#6

I am currently testing the AOI Monitoring tool. Looks very promising at first sight, also the integrated Copernicus download!


#7

6.0 beta incorporates those fixes, please try it out. We are going to do further improvements in the upcoming versions.


#8

Hi all.
When I run Snap 6.0 beta version as remote user (i run Snap installed in another workstation with terminal interface. Both workstation has ubuntu 16.04 and Snap 6.0 beta version), snap returns this message:

.
After closing message, all the features that I use seem to work well, except for World View that is disable (and so it is impossible to see a preview of the images’ footprint ).
I don’t know if is a driver problem of my machine or a snap’s compatibility issue.
Thanks for your help.


#9

There have been every now and then driver problems with the WorldWind View. Especially on Unix. But this one is new. I haven’t seen it before. Maybe you can fix it by updating the driver of your graphics card.

Maybe what I wrote in the following post might help you:

And/Or this one:


#10

Thank you! I’ll let you know as soon as possible.


#11

Here a list of issues found after testing SNAP version 6 BETA (preview4).

  • Sentinel-2 cache clean up seems to work well after the bug fix reported here:

https://senbox.atlassian.net/browse/SIITBX-261?page=com.atlassian.streams.streams-jira-plugin

By the way, there are problems related to the clean up of the entire s2tbx cache folder, as I have recently reported in this post (and affect also SNAP6):

  • BiophysicalOp operator still runs using a single core when is called in gpt from a graph, as reported here for SNAP 5:
  • External Tool ‘iCOR’, perfectly working in SNAP 5, seems to have problems in SNAP 6 related to Sentinel-2 metadata:

    Traceback (most recent call last):

    File "c:\Program Files\VITO\iCOR\src\icor.py", line 44, in process_product
    
      icor.sentinel2.process_tar(context, product,working_folder)
    
    File "c:\Program Files\VITO\iCOR\src\icor\sentinel2.py", line 72, in process_tar
    
      granules = sentinel2_metadata.parse(path,bandList)
    
    File "c:\Program Files\VITO\iCOR\src\icor\sentinel2_metadata.py", line 279, in parse
    
      raise Exception("Something went wrong while parsing the S2 metadata file: %s" % str(e))
    

    Exception: Something went wrong while parsing the S2 metadata file: not well-formed (invalid token): line 1, column 0
    parsing arguments
    done

Federico


#12

Hi all,

I noticed the following unusual behavior when using gpt in SNAP 6.0 Beta.
I developed a graph using SNAP 5 for Sentinel-1 processing. I could ran it without problems via gpt batch processing and it delivered the desired results (intensity Gamma0 values). Then I migrated to SNAP 6.0 by doing a clean new installation.
When I’m running the same graph via gpt under the new version, suddenly two output products per band (Gamma0_VH & Gamma0_VH_2/ Gamma0_VV & Gamma0_VV_3) are created. The biggest problem is that both products differ in pixel values.
I already tried different input products, but the error stays the same.
Here is a link to a dropbox folder containing the processed files (out of frustration everything including the .dim file, so I have only the .img and .hdf files left) and also the xml file and the corresponding bat file. The scene that was processed in this case is S1B_IW_GRDH_1SDV_20170711T170628_20170711T170653_006443_00B539_29A5
https://www.dropbox.com/sh/4d88v9zjlckr393/AACVILTrchye7unvJ_ldRdZta?dl=0

Maybe someone is experiencing similar issues?
Right now, I switched back to Version 5, since I’m in great need of the batch processing function via gpt.

Anyway, great new features (the AOI monitoring tool is really neat!) :slight_smile:

Regards,
Denise


#13

What’s the difference between the results in SNAP 5 and SNAP 6. Is it huge? Maybe there was a bugfix which has an effect on the values (@junlu )? Maybe the new values are better?


#14

As you asked, I compared it to the processed product from SNAP 5 (I call the bands now VV_S5 and VH_S5) to the ones in the provided Dropbox folder (simple subtraction):

[intensity values]
Gamma0_VV and VV_S5: no difference
Gamma0_VH and VH_S5: no difference

Gamma0_VV_3 and VV_S5:

Gamma0_VH_2 and VH_S5:

VV difference image:

VH difference image:

The biggest question for me is: Why is ist producing two different results in the first place?


#15

This looks like a bug. @junlu please check


#16

We will look into it


#17

I think something is off with the max memory retrieval from gpt.vmoptions-

In gpt.vmoptions I have:

-Xverify:none
-Xmx43G
-Xms2048m
-XX:+AggressiveOpts

Yet, when I run gpt --diag I get a much lower max memory

SNAP Release version 6.0-PREVIEW4
SNAP home: /opt/snap/bin//..
SNAP debug: null
SNAP log level: null
Java home: /opt/snap/jre
Java version: 1.8.0_102
Processors: 8
Max memory: 38.2 GB
Cache size: 1024.0 MB
Tile parallelism: 8
Tile size: 512 x 512 pixels

System: Ubuntu 17.04 or SUSE Linux Enterprise Server 11 SP4


#18

Gamma0_VH_2 and Gamma0_VV_3 should not be there. The bug has been fixed.


#19

Hi annamaria,

I’m experiencing the same error as you regarding worldview (although in SNAP 5). Did you already find a solution?

Best,

Val


#20

Unfortunately no.
all the best,
Annamaria