Loading of RapidEye imagery - no .rbg file to load image in colour

I’ve downloaded the latest version of SNAP and opened a RapidEye image. However, since there’s no .rgb file for the RapidEye imagery (2012), the image can only be viewed in B&W. Pls note that the same RapidEye image was opened successfully in ESRI Arc and Erdas Imagine.

Has anyone ever processed a RapidEye image in SNAP ? If so, could you kindly indicate the process to load the image and view the bands in RGB ?

Thanks
Elaine

Hello,

If you can open the data in ESRI and Erdas, maybe convert the data to Geotiff or ENVI format and then try opening it in SNAP.

Hi @escib

It is pretty simple.
Right click on the product in the Product Explorer and select “Open RGB Image Window”.
Then you can manually assign the bands for R, G and B channel.
You can also name and save your choice, to reuse them later.

But the Sentinel-2 Toolbox provides a reader for RapidEye datasets (L1 and L3), which comes with a predefined RGB profile. Thus I assume :

  • you did not install the S2TBX
  • or the format of your product is different from the one we support.

Process to open RapidEye_no RGB.docx (623.4 KB)Hello
Thanks for your feedback but none of the above worked.

  1. Manually assigned bands to the RGB channels, but the image that appears is still in B&W (refer to screenshots in attached doc).
  2. Re-installed SNAP 2.0 Windows 64-bit and ensured that the S2TBX is installed.
  3. Exported as GEOTIFF using Erdas, but still the same problem.

The RapidEye image was acquired in 2012. The file formats for this image, as provided by the satellite distributor, are .tif, .tif.aux.xml, .tif.xml, and .tfw.

Hi again,

Did you look in the “Colour manipulation” tab ? Maybe there is something wrong there because of a no-data/saturated value spanning most of the image.

Can you share the product so that we can test it ?

Hello @escib.

The structures of the RapidEye products that S2TBX supports are:

  • for L1: <product_name>_bandN.ntf (N=1…5), <product_name>_metadata.xml, <product_name>_rpc.xml, <product_name>_sci.xml, <product_name>_udm.tif, <product_name>_browse.tif;
  • for L3: <product_name>.tif, <product_name>_metadata.xml, <product_name>_udm.tif, <product_name>_browse.tif
    These are according to the RE_Product_Specifications_ENG.pdf (1.1 MB) document.
    Moreover, from the screenshots you have attached, I see that the <product_name> doesn’t conform to the above specs.

Could you please share the product you’re trying to visualize via DropBox or OneDrive so that we can take a closer look to it? Or, at least, provide your email address so that I can share a OneDrive folder with you?

Hello
@jmalik and kraftek:
Could you kindly email information.resources@mepa.org.mt ? I’ll then proceed to send you the image via a webtransfer link.
Thanks
Elaine

Dear All
Further to the product specifications email from @kraftek, SNAP does open the original unprocessed L3 RapidEye image.
What we had tried to load onto SNAP was a processed version of L3 (i.e. a merged satellite image which consisted of 3 original L3 images merged to cover our AOI). Consequently, the resultant merged image lost the udm.tif and the metadata.xml file.
So that seems to have been the problem in that SNAP would read the original unprocessed file properly only.

Thanks
Elaine