Missing part in processed GRD to Sigma0

I am encountering an issue with conversion from GRD product into calibrated Sigma0. It occurs with following GRD file:

The issue is clearly visible in following screenshot:

A part in the upper left corner is missing. It happens in both the VV, and VH bands, as well as in the incidenceAngle band.
The processing graph that I used is here: GRD_Processing_dB.xml (7.6 KB)

Can someone tell me what happened here? @mengdahl, @lveci, any ideas?

Perhaps a DEM-tile is missing?

Allright, so it looks like that is indeed the issue. Is there any workaround to process GRD products that overlap a missing tile over ocean, so that these areas would still be processed and not result in a gap in the image?

you could use another DEM. As it looks, your study area doesn’t have much topography anyway.

That’s correct :slight_smile:
However, it looks that only the part over North Sea is a problem, as that tile is missing in SRTM. Just tried out the “mask out areas without elevation” and this also resolves the issue. Now, in practice, should that be something we can use in operational processing over Belgium? Does it in practice just assume DEM of 0m when there’s no valid data?

Not always, sometimes using SRTM1 arc second within SNAP sea areas had not 0m height.
Looking at the metadata also gives you the nodatavalue parameter needed to work with the data.

You can create dummy SRTM tiles for the missing degrees grid cells setting all values to 0 and dump these in the auxdata path for the relevant DEM tiles. SNAP will process these as usual (i.e. no need to mask out areas).