NullPointerException in Wind Field Estimation

Hello! May I ask what is the proper way of processing GRD IW images from the scientific data hub for wind field estimation?

So far, I have tried calibrating it, followed by speckle filtering, then range doppler terrain correction only to receive the error java.lang.NullPointerException when running wind field estimation


If your data is over the ocean, you won’t be able to use terrain correction.
Just calibrate and run wind field estimation then if you like run RD ellipsoid correction.

Also, the Level-2 wind products are available on scihub which have a lot more information then this operator.

Hi Iveci! Thank you for the reply. We would like to know if it is possible to run wind field estimation after RD ellipsoid correction? We wish to obtain the correct locations and directions of the wind vectors in the wind field report but we are not sure if doing the RD ellipsoid correction after wind field estimation will produce that.

We tried doing this, but we were once again met with the error java.lang.NullPointerException.

Hello @lveci!

My question is very similar - I also use GRD EW and IW data, and I would like to have nice wind fields. I follow your procedure exactly: Read --> Calibrate --> Wind field estimation, but every time I and up with a file with no wind information at all (so my output *.geotiff file contain only HV and HH bands, no wind vectors). I tried with different window sizes (from 5 km to 50), the result is the same.
It might be possible that the masking doesn’t work properly for me - if I choose “Mask out the land” with/without “Use SRTM 3 sec”, nothing happens as well (I tried this procedure separately).

As for Level-2 data - there is not much in my region of interest (Arctic area, e.g. the coastal zone of White sea), and if I understand it properly, by this moment L-2 is produced only from WV mode imagette that are really sparse.

1 Like

If you area is the Arctic then the SRTM won’t be of any use. In this case use the fractional water mask operator instead.
The windfields produced by SNAP are intended to be shown as overlays via the layer manager. Exporting to GeoTiff may lose this information.
Level-2 include OWI windfields gets produced from all modes.

I was having similar problems - my mistake was that the wind data was being created but I wasn’t loading it. Then I found out from the Help that the wind data is only accessible from the ‘layers’ menu. So this is what worked for me

select the source band > go to layer manager > add using the plus button - then add wind data. Arrows should appear then.

1 Like

@con20or Oh, nice! In this way it works, thank you!

@lveci Thank you for your answer! The fractional water mask operator works fine for me as you said ! The question about exporting full data (backscatter + wind vectors) in the same file seems to be open, nevertheless… I looked through the forum topics on wind estimation function and got that the only solution now is shell scripting (to access the wind vectors from /.snap/log/ directory) and GDAL (to deal with data outside of SNAP furthermore), right? Personally, I would prefer to have an option of saving everything in one netcdf (just as idea for future releases).


Wind fields are now added to the products vector nodes. You can then export the vector node as a shape file.


Hello Iveci,

I have been countering similar issues even after 4 years.
Could you please help me solve this?
I will just brief what I have been trying. As per your posts, I have calibrated and run Wind field estimation on EW- Medium resolution image, which works fine and the wind vectors are generated.

But then, after projecting it to Polar stereographic-South (My study area is Antarctic-hence used without SRTM as suggested by you in previous comments) using Ellipsoid Correction-GG, I see only the band is projected and the wind field isn’t.
How do I solve this please?

It is similar for the ship detection, the results are lost after geocoding. Ship Detection - cannot export Geometry as Shapefile

@lveci is this a systematic bug?

1 Like

Hello Iveci,

The window size is given in km for the field estimation, but the wind speed after plotting shows 0.10m/sec (it just can’t be the right one since it can not be physically possible).
Is it km that is a bug or truly meters? Or am I not interpreting it well?
Is there any document or tutorial that can help with this please?