Oil Spill Detection Tools Bug

When I run this tool (Radar → SAR Apps → Ocean Apps → Oil Spill Detection) it stops at 21% to the desktop PC and at 15% to the notebook.
I have installed the full package and I tried to change some settings. But still is not working.

I have SNAP 8.0.10 and my PC has 16GB RAM. Is an issue associated with locale settings of Windows? I have Windows 10 Greek and some paths use Greek letters (e.g., user path). Have you faced similar issues? Note that I haven’t faced such issues with S2 Toolbox.

Thanks

Sounds like a case where the SRTM 3Sec could not be downloaded in the Land/Sea mask operator. Does this step work when you execute it manually?

I will test it. But in the folder “c:\Χρήστες\Διονύσης.snap\auxdata\dem\STRM3Sec” there are downloaded files with sizes between 20601 and 37759KB.
The strm_46_07.zip which is used by the specific project has a size of 20601KB.

Finally, I have tested it. The downloaded file has a different size of 20612 KB.
However, the problem remains.

Dr. Dionysios Tompros

I’m not sure if the size difference is a problem here.
If you delete the SRTM file of your project, then manually execute the Land Sea mask operator, so that the file is retrieved, then execute the Oil Spill detection again, does it work?
Does your scene partially cover land? Otherwise you could skip the land masking.

I have tested it by two ways:
i) I deleted the SRTM file in order to retrieve it again (and also, I changed the URL in the file C:\Program Files\snap\etc\snap.auxdata.properties at DEM.srtm3GeoTiffDEM_HTTP =http://skywatch-auxdata.s3-us-west-2.amazonaws.com/dem/SRTM90/tiff/) and
ii) I replaced the file with the downloaded one.
Finally, I skipped the land masking with SRTM but the problem remains.
The algorithm stops at 21%

Is there a problem with HTTP connection (HTTPS issue)?

Dr. Dionysios Tompros

can you manually create the graph in the Graph Builder without the Land/Sea mask operator?

I have tested it and still, I have the same problem. Now the algorithm stops at 19%.
I attach the graph. I have put the calibration stage because the graph builder informs me that the image is not calibrated. “Error: [NodeId: Oil-Spill-Detection] Source product should be calibrated.”.

Thanks for your patience,
Dr. Dionysios Tompros

Thank you for testing.
Could it then be that your input image is too large?
What data are you using by the way?
Maybe testing with a small subset brings clarity.

Thanks for your time.
My file is a subset with a size of 6720 KB. Finally, the problem is caused by the speckled subset image.
I tried to change the speckle algorithm from Lee Sigma to simple Lee but the result is the same. The Radar Oil Spill Detection stops at 21%. When I used the pre-speckled image the Oil Spill Detection algorithm gave a good result but the image is unspeckled.

Dr. Dionysios Tompros

as an alternative, you can apply Multi Looking instead of speckle filtering to reduce the file size and also to reduce speckle.

Dear Andreas Braun,
it seems that the problem is caused by the algorithm Oil Spill Detection.
I used Multi Looking, but the issue was raised again (it stops at 21%).

Dr. Dionysios Tompros

Can you please show a screenshot of the input image?
Does it contain a clear oil spill?

This is the screenshot after the Speckle Filtering (Single Product) :

Dr. Dionysios Tompros

I still guess SRTM is the problem.
Please try this:

  • Digitize a polygon around the water areas you want to detect in the input image.
  • In the Oil Spill Detection > Land/Sea Mask > Disable “Use SRTM 3Sec” and instead select “Use Vector as mask” and select the geometry. Then run the module and check if it completes.

I have followed the instructions, but the module doesn’t complete its work. It still remains at 21%.

Dr. Dionysios Tompros

Very strange. I’m afraid I’m out if ideas.

Dear Andreas,
thank you for your time.
Meanwhile, I downloaded another case of the oil spill (Saronikos-Greece, 13 Sept. 2017), and the detection algorithm works. But when I add the speckle algorithm it stops again.
I will check it on the weekend and I will inform you again.

Best regards,
Dr. Dionysios Tomrpos

BTW wouldn’t it make sense to remove Thermal Noise too as it is artificially raising the signal-level of the darkest areas that are close (or under) the noise-floor?