Phase to elevation - BLACK product

I used different combinations:

  1. S1A_IW_SLC__1SDV_20180904T143846_20180904T143912_023550_029096_5D58 and S1A_IW_SLC__1SDV_20180916T143846_20180916T143912_023725_029633_5AA5
  2. S1A_IW_SLC__1SDV_20190327T143844_20190327T143910_026525_02F8DC_066B and S1A_IW_SLC__1SDV_20190408T143844_20190408T143910_026700_02FF4D_9379
  3. S1A_IW_SLC__1SDV_20180916T143846_20180916T143912_023725_029633_5AA5 and S1A_IW_SLC__1SDV_20180928T143846_20180928T143912_023900_029BE2_BC4E

but the result was black screen. I found the same problem, but i don`t understand how to correct it.

BUT I repeated all steps for products from Alaska tutorial and everything is OK (but the the elevation ranges doesn’t match reality, of cource).

How it works, I dont know…Why I can not create elevation for my region?

I think this post is quite good start for you, also remember the criteria of SAR IMAGES before to go a head in the processing for example the perpendicular baseline is a key point of created the elevation map,

Also, please have a look at this,


I think it is very nice tutorial, but let’s do it easy,

1- Split, Select where is your AOI in which subswath IW1-IW2-IW3,
2- Apply orbit,
3- Back geocoding
4- Apply ESD
5- Create an Interfogram
6- Deburst
7- Goldenstein Phase Filtering
8- Multilooking
9- Phase Unwrapping by selecting TOPO mode and and MCF, in the step of the SNAPHU EXPORT
10- Phase to elevation
11- Range doppler terrain correction.

Put in mind that the parameter altering is important and according to the many conditions, use the default in the beginning and then start to change them.

For the step of applying ENHANCED SPECTRAL DIVERSITY ESD, it could be found from here,


I checked baseline (the range between 150 and 300 was not possible to be, max about 135).
I checked local weather and other parameters, but I still getting black final products.

Maybe I do not understand because of lost in the translation or my carelessness, but I will try it after a little rest.

In any case, thank you so mush!

Please try up to follow the step I mentioned to you in the previous post.

I follow the mentioned steps.



  1. Result is

I used another products too, but the result is same.

Are both images form the same orbit Ascending or Descending ?

And Are they cover the same slice and track number?

In step one , did you select the same number of bursts and IW, of each image?

Did you use SRTM 1sec HT, auto download? (This doesn’t cover your study area, should not be selected and SRTM 3sec either)

Is your machine connected to the internet?

IF the answer of the previous questions is , yes , it means your SNAP has problem,

Because you mentioned, that you used other products and the results are same!

" select the same number of bursts and IW, of each image" - of course.
“use SRTM 1sec HT, auto download” - I used 3sec, cause you wrote

“machine connected to the internet” - of course.

How to check orbit? In metadata?

But all was right, when I made DEM for Australia

First thing in apply orbit , check the box , don’t fail, as it is mentioned in this post,

Also be sure to choose the precise sentinel orbit,

Your previous post is mixing different thing,

Could you implement again your Asturalian process and check up your steps.

At the moment don’t change any of parameters and leave they as default.

By the way how did you implement the unwrapping step?

I think the problem in the unwrapping step, after export to unwrapping and then unwrapping the phase , once unwrapping is done drag and drop the unwrapped phase.
In read phase add the one before export to unwrapping, and in the unwrapping phase add up the unw.hdr phase resulted from the step of SNAPHU,

Take a look at this post, it shows how to implement unwrapping

1 Like

In first step I took Orb_Stack_ifg_deb_flt_ML product, in the second I took my SNAPHU hdr file.
But where exactly should the file be? In what directory? because I have it in a separate folder.

In the third step I check the box “DO not save …”

Have a look at the previous edited post please, Check up in which directory did you save the SNAPHU results, you should save your result.

Also an important thing in TOPSAR backgeocoding check the boxes deramp and demod,

As it is mentioned in here

OK, I will try.
Thanks for your advice

So, I repeated all steps for Alaska tutorial data, and for my AOI on my PC and on my laptop. Everything were OK for Alaska tutorial data, but I still can not create DEM for my AOI. I checked data here; I drag and droped unwrapped phase

but ineffectually… I don`t know what is wrong with me :sweat_smile:

I think we could find solution, I edited this previous post,


Because, I think both SRTM 1 Sec and 3sec don’t cover your study area, and the good solution at the moment to try up select GETASSE30 (Auto-download) in the step of backgeocoding, because it covers your AOI,

GETASSE30 Elevation Model

Other thing I’d like to refer to this thread, because it covers the same your AOI,

Option of backgeocoding in Alaska

Hmmm, OK, I will try once more!))
Thank you very much!

But also I think, that, perhaps, problem is in AOI, because there are many little lakes and rivers, settlements, diverse LandCover, and, what is not less importantvery, I think, small change in elevation, only about 2-3 meters over many kilometers

Well, I repetead all steps once again, but for slightly different territory (North Caucasus).

There were no problems, and DEM was created.
But, I have another questions. I know, that all of this questions were on forum, but I can not find them, so, please, help me once again.

This is SRTM DEM

And this one by Sentinel data

Why we can see on pic different anomalies, like this?

And how to correct elevation values?Screenshot_5

Let’s discuss the matter one by one,

First point I mentioned in here the selecting SAR pairs conditions for DEM creation

In case we try up to apply all the aforementioned conditions to your case, or Sentinel -1 case, we could find that, more than one of S1 characteristics don’t meet the DEM creation, and example of that is, the temporal baseline, as you know, there’s no tandem pass in S1, also the perpendicular baseline is important to take in account as it is mentioned,

Here our colleague @ABraun has mentioned the properties and increasing the quality of DEM

In our colleague post you could find out the lack of S1 for DEM creation, and the solution of increasing the DEM quality by multi-looking to 20 m, and goldstein filtering,

Other way to increase the quality of DEM creation is to by Interferogram averaging for DEM generation

Coming back to your results, concerning the SRTM DEM, I think it is incomparable with the S-1 in most cases (personal opinion) for example following are some reasons,


Other reason,



BUT BUT BUT, That doesn’t mean to stop our research to creating DEM from S-1, especially in the real need when SRTM or other DEM missions don’t cover the AOI,

I think your results are good, think about the Unwrapping method we use, Unfortunately there is no other approach of unwrapping is available could be used to compare the results or at least to be more affable to one case rather than the other,

Technically I found you passed all the steps successfully, you got very good results so far, Now, my advice to you is, to start change the parameters, in each step starting from the ESD, reaching the last step of processing,

The difference between S1 DEM yours,




I think they are reasonable, according to what are mentioned above,

Your mission now is , to follow the approach I gave to you within this post to decrease this differences as much as possible.


Well said, @falahfakhri!

So, I also write “well said”, and thank you very much!))

, after Caliberation?

referring to the falahfakhri`s tips

we should do multilook after Phase Filter.

According Alaska tutorial, it is possible not to do.
Personaly, I tried different options