Pre and Post processing reflectance values are the same - Sen2cor


I tried to run Sen2Cor v2.8 in some images L1C from 2019, applying the automatic parameters, but when I compare the histogram of the reflectance in the output data, it is exactly the same than the L1C data. I looked at the reflectance values of some chosen polygons on ArcGIS and they are also the same in both pre and post processed images.

Any idea of what I could be doing wrong?

Thanks :slight_smile:

Briefly, this is the core work of sen2cor,


Where exactly the AOI ? , Does it has any of aforementioned atmospheric objects?

One examination could be done now is, apply AC, sen2cor to only Resolution==10 , and then compare both the LIC and L2A, in case you didn’t done it yet.

1 Like

Yes, I have alredy done for 10m…Its a lake in the south of Brazil called Lagoa da Conceição.
The image does have some small clouds…Anyway, I tried to run the Sen2Cor for an image of 2019 that has already level 2A provided by ESA, and the level 2A has considerably different values, while the one I applied the correction is exactly the same as L1C. I tried for images of 2018 and 2016 as well (but then I had no L2a to compare). They continued the same as L1C. Never seen this before? I have no ideia of what I could be doing wrong :confused:

Might be @obarrilero could give his opinion in here,

The values of the L2A product provided by ESA and the one generated by yourself in Sen2Cor are not going to be identical as they are using a different DEM (and also perhaps your configuration parameters are different). In any case, the reflectance values should be different to the L1C.
Have you selected the options “scene only” or “cr only”? In these cases, sen2cor is not computing the BOA reflectances.


No, I haven’t selected that options…Is it right to change those paramethers (rural - maritime), (winter - summer) to AUTO and ozone to zero? I read in the users guide saying that it would make the sen2cor decide. It was the only parameters I changed to see if it would work…Anyway, what I reported here not a common problem, right? Thanks for your help guys! I think I will give up for now, hope the next time I get more luck :slight_smile: