Problem in the last part of snap to stamps

Dear Friends,
I have a strange problem with my snap to stamps PSI procedure.
I have done several projects using the current configuration of my system. but recently a new problem has occurred. I can do the first three steps of the snap to stamps procedure very well. as soon as I start the Stamps PSI export (step 4) the system can not continue running and the command window will be halted. The system is Okay and there is no hanging problem. My problem is just on the fourth part of the snap to stamps procedure. The strange part is my system is able to redo my previous projects from zero to 100, while new projects will be stoped on the fourth part.
I look forward to hearing from you my dear friends.

1 Like

When I used the stamps export in snap2stamps lately I experienced the same problem (probably also the case here)
Does it work from the GUI with a single pair?

I can’t think of a reason why this happens, because I don’t think there were changes in this module.

@jun_lu: Has the stamps export been modified lately?

Hello, There is no modification on the Py files or system configuration. It works when I use my previous projects correctly. It does not work for my new projects. I checked several new projects with different downloaded photos. in all new conditions, I have the same problem.

I also copy a new Py files in to Bin folder of snap-stamps to become sure there is no any modification on my files. same condition was saw.

Unfortunately my problem did not solve yet.

what about this?

this would help to narrow down the error source.

I have the same problem.
I tried to down-grade the SNAP version but it didn’t help.

To control the GUI procedure I used this tutorial “” and found that I have an Error (stopped the procedure) in the phase of BackGeocoding. In addition, I used such a method on another PC and have the same problem.
The procedure steps are as follows,
1- Split
and so on

It is stooped on computing raster data on Back Geocoding procedure.

yes, because of the current SRTM error. SRTM ZIP-files are corrupted or not found

Please select SRTM 1Sec HGT (AutoDownload) instead, the error will be fixed with the next update.

I tried with mentioned DEM but had same problem. In addition, My snap Version is 7.

the problem is not related to the SNAP version, because the server location of the SRTM data has changed.

It was reported that a clean re-install of SNAP (including deleting the user configuration data) solved this error.

Do you exactly mean I have to uninstall my snap and reinstall considering deleting the user configuration data in the installation part?

yes, this should fix the issue

Thank you for your help,
My problem on the Back Geocoding with Snap did not solve with reinstallation while it is solved by

changing the downgliding to 1Sec. (I highly interested to find the solution to this problem)
Now I had an Ifg file.
When I started to finalize Stamps export the procedure is stopped on 4% .
I think it is my main problem considering my first question about the fourth step in the snap to stamps procedure. This means stamps Export doesn’t work in GUI as well.

I also tried with a newly installed Snap on Windows, The same problem occurred. I think there is a mistake in Datacenter or ESA server???

an explanation on this problem (and a manual solution) is given here:

Thank you so much for your prompt help and consideration. My problem to generate Ifg is solved. now I have an excellent Ifg file. I started to export the project to Stamps using Snap to Stamps from ~Interferometric/PSI/SBAS. The command will start and it will be stopped at 4 percent. I used a Different version of snaps. In addition, as I explained before I had the snap to stamps problem in phase 4.
This is now my main problem.

here we are all at the same problem.

@mdelgado Do you have an idea why the StaMPS export from SNAP (and in snap2stamps) does not finish?

@jun_lu Have changes been applied to this operator lately?

Which version of SNAP is using?

With snap v6 the operation works perfectly, despite the fact of creating a target.dim in the folder where the script is called

Months ago I got a snap 8 snapshot where the operator was not working as it should , but I hope they solved it. I cannot confirm as I have not tried yet